2 Replies Latest reply: Feb 6, 2013 12:42 AM by brunors RSS

    ORA-04031

    564303
      OS :Windows 2003 R2

      DB Ver : 10.2.0.4 Ent Ed.

      Downstream DB

      When start capture , capture abort following error,

      ORA-04031: unable to allocate  bytes of shared memory ("","","","")
      ORA-04031: unable to allocate ORA-04031: unable to allocate 18322328 bytes of shared memory ("streams pool","unknown object","streams pool","internal ddl lcr")
      bytes of shared memory ("","","","")

      1.We Increased SGA_TARGET and STREAMS_POOL Size ,but same error.
      2.We have restarted OS also same error

      Regards
      Murali R
        • 1. Re: ORA-04031
          asahide
          Hi,

          32bit or 64bit??

          What's your initialization parameter?
          SGA_MAX_SIZE, SGA_TARGET, shared_pool_size etc..

          Regards,
          • 2. Re: ORA-04031
            brunors
            Hi, how do you told that restarted your SO, I I would talk to you execute the command "ALTER SYSTEM FLUSH SHARED_POOL;" but this is not apply. I looked in the utility Oerr and he presentation;

            oracle> oerr ora 04031
            04031, 00000, "unable to allocate %s bytes of shared memory (\"%s\",\"%s\",\"%s\",\"%s\")"
            // *Cause:  More shared memory is needed than was allocated in the shared
            // pool.
            // *Action: If the shared pool is out of memory, either use the
            // dbms_shared_pool package to pin large packages,
            // reduce your use of shared memory, or increase the amount of
            // available shared memory by increasing the value of the
            // INIT.ORA parameters "shared_pool_reserved_size" and
            // "shared_pool_size".
            // If the large pool is out of memory, increase the INIT.ORA
            // parameter "large_pool_size".

            Kind regards, Bruno Reis.
            www.brunors.com