7 Replies Latest reply on Feb 7, 2013 10:52 AM by User_OIM

    BadPadding Exception in OIM 10g

      Hi Guys,
      I am getting the below error in my QA OIM Environment after I migrated configurations from my Development Environment. It seems that the error occurs when the reset AD password task is triggered. After looking into the error, I've come to a conclusion that this might be due to the fact that the QA OIM is unable to encrypt/decrypt the password being set by the reset AD Password adapter. The same code is working perfectly fine in my Development Environment. I also tried replacing the tcCrypto.jar in QA OIM lib directory by tcCrypto.jar from Dev OIM lib directory. After doing this, I retried a failed reset AD Password task in QA OIM and it worked perfectly fine. But when I tried doing it again, I got the same error. What could be the reason for this. I have already replaced the tcCrypto.jar file thinking it might be due to a corrupt library jar. I couldn't get much help from this forum from the old threads too. Please help.


      Class/Method: tcDefaultDBEncryptionImpl/decrypt encounter some problems: Given final block not properly padded
      javax.crypto.BadPaddingException: Given final block not properly padded