2 Replies Latest reply on Feb 7, 2013 7:25 AM by Dennis DS

    Upgrading from 4.1 to 4.2.1 does not load the images (EPG)

    Dennis DS
      Hi all,

      I had a problem upgrading APEX from 4.1 to 4.2.1 using the full installation with all languages.

      I managed to solve this myself, but still I am not sure why it failed the first time. This is why I post this message. Also, to help others who stumble upon this problem.

      - I am trying to install APEX 4.2.1 on Oracle 11g XE.
      - I am using the embedded plsql gateway (epg)

      1) I unzipped the file to C:\Oracle\apex_4.2.1\apex

      2) From that directory I started sqlplus:

      C:\Oracle\apex_4.2.1\apex> sqlplus sys as sysdba


      sql> exec dbms_xdb.sethttpport(0);
      sql> @apexins.sql USERS USERS TEMP /i/
      sql> exec dbms_xdb.sethttpport(8080);

      Then I restarted the listener.

      I went to localhost:8080/apex it forwards to localhost:8080/apex/f?p=4550:1:<sessionID> using Chrome. But a blank screen appeared. This is something that happens to a lot of people (I read many of these problems on the forum)

      After some investigation I noticed the script didn't create the new images directory. I still had the images directory of 4.1! So I backupped the old images directory and uploaded the images directory manually using fileZilla (logging in with SYSTEM)

      Then when I tried to go to localhost:8080/apex/f?p=4550:1:<sessionID> I got this popup: "The server localhost at XDB requires a username and password."
      This happens in all major browsers (IE, Firefox, Chrome)

      By searching on the forum I found posts stating this is an IE 7 problem, that I have to run this statement: "alter user xdb unlock account;" But I tried this with no avail. I kept getting the prompt. When I clicked cancel I couldn't seem to see anything. When I used sqlplus xdb/xdb@xe it worked fine.

      Next thing I tried was removing the images directory manually. Then I ran @apxldimg.sql (without parameter) and the images directory was recreated, but it magically contained the old files from 4.1! When I went to the images folder on the installation drive I could clearly see a folder images/apex_ui but it simply didn't exist in the database after running apxldimg.sql.

      Then I found something in the code of apxldimg.sql. Apparently it creates a directory on the database using &1/apex/images... So the substitution variable "&1" should have been the location of the local files and it must contain the full path!

      sql> @apxldimg.sql C:\Oracle\apex_4.2.1

      After running this the files were created succesfully and I could finally log in.


      One question remains: Why can't I find anything in the log file about loading the images? And why didn't it work via apexins.sql? It completely skipped this step, as no trace of it was found anywhere in the install log. Could this be a bug?


        • 1. Re: Upgrading from 4.1 to 4.2.1 does not load the images (EPG)
          Jeff E

          The apexins.sql script does not take care of installing/loading the images. Installing the images has always been a separate step which is often overlooked (it is a different process depending on the HTTP server one has chosen to use). http://docs.oracle.com/cd/E37097_01/doc/install.42/e35123/otn_install.htm#BHAJIGDA
          The majority of the "blank page" problems on new installs is because of the images not being loaded properly.

          • 2. Re: Upgrading from 4.1 to 4.2.1 does not load the images (EPG)
            Dennis DS
            Hi Jeff,

            Sorry to have been stating the obvious. As you mention, it is clearly in the documentation. I can't believe how I missed this if it's right in the documentation. It is kind of embarassing, but then again I am happy to have learned something from it: "RTFM" :-)

            Anyway, thank you for pointing this out!