2 Replies Latest reply on Feb 8, 2013 4:55 AM by user301482

    ACFS config error on ODA


      I have encountered an ACFS related issue. Since there is no ODA forum I believe this is the most appropriate forum.

      Before raising any SR I am posting here as per My Oracle Support guidelines. I believe I have also exhaustively reviewed the the documentation, MOS KB and these forums looking for solutions.

      I have been following MOS Note instructions to "Setup ACFS Post Deploy" [ID 1435019.1]

      At step 5 I ran "/opt/oracle/oak/onecmd/GridInst.pl -s 22" as per the instructions, with the following result;

      ERROR : Error in running /opt/oracle/oak/onecmd/tmp/asmcacreatevol.sh
      Volume acfsvol created successfully.

      Connected to an idle instance.
      ASMCMD-8102: no connection to ASM; command requires ASM to run

      I suspect some environment variables were not set since both "srvctl status asm" and "crsctl stat resource -t" indicate that ASM is running

      There is nothing in the MOS note about setting environment variables.

      Step 6 indicates that the filesystem is still not mounted ie. no result for "mount | grep cloudfs"

      Running the command from the other node has the following result;

      ERROR : Error in running /opt/oracle/oak/onecmd/tmp/asmcacreatevol.sh
      Volume acfsvol creation failed with the following message:
      Volume acfsvol already exists. Cannot be created again

      The error above suggests to me that some manual intervention may be required.

      I am both asking for troubleshooting input and doing the due diligence before creating an SR.


      Edited by: cvdv on Feb 6, 2013 11:46 PM
        • 1. Re: ACFS config error on ODA
          Sebastian Solbach -Database Community-Oracle

          since this is ODA related, I would create an SR, since this should not happen.

          A workaround probably is pretty easy, but not recommended as this is ODA.
          You can call asmca manually (as User Oracle and having an x-term anyhwere).

          But since it already created the volume, probably what is missing is the ACFS format (mkfs -t acfs /dev/asm/<volname>)
          And the mount command. It could also be that ODA registers the filesystem with (srvctl add filesystem).

          • 2. Re: ACFS config error on ODA

            Thanks for confirming my ODA/support concerns.

            Additionally I'll include your workaround/troubleshooting suggestions in the SR as they may prove helpful.

            It's interesting that the volume was "created successfully" (via some shell based os command/utility?) whereas the next "idle instance" message indicates the script was possibly trying to perform a query or update when it failed/aborted.

            I might make some time to check the /opt/oracle/oak/onecmd/tmp/asmcacreatevol.sh script to confirm my guesses.

            Regardless you've answered my question, even if it does not solve the problem.