4 Replies Latest reply: Feb 11, 2013 9:16 AM by 972227 RSS

    ORA-12547: TNS:lost contact

    972227
      OS: AIX 6
      db Version: 11.2.0.3.0

      here is the scenario guys, one of our servers containg the test databases crashed (don't know how), so the server is completely empty now and we have to build everthing from the scratch. What I did was, I created a tarball of Oracle home from another server and ftped it to the test server and unzipped it, changed the ownership to oracle user.

      Now when I am trying to create duplicate databases I am getting the error ora-12547.

      Here is what I did to try to solve the problem.
      1. I changed the listener.ora file (by change I mean, I replaced the ipaddress of the production server from which the tarball was created with the ipaddress of the test server where we have to rebuild the databases)

      2. After changing the listener.ora file, I restarted the listener several times and made sure that all the path variables are set and did a "*relink all*".

      3. I set LD_LIBRARY_PATH to *$ORACLE_HOME/lib* like some blogs mentioned.

      4. I went through metalink and they mentioned about changing the permission of the oracle binary in $ORACLE_HOME/bin. so I did *$chmod 6751 oracle*.

      Now I created the pfile and the password file for the database I want to build and tried to bring the database in a nomount stage, here is the result I got.
      <oracle>chh-aix-beta/home/oracle> sqlplus / as sysdba
      
      SQL*Plus: Release 11.2.0.3.0 Production on Fri Feb 8 18:13:35 2013
      
      Copyright (c) 1982, 2011, Oracle.  All rights reserved.
      
      ERROR:
      ORA-12547: TNS:lost contact
      
      
      Enter user-name:
      Where am I going wrong? are there any additional steps I need to follow?
      I am guessing, if I could bring my database in a nomount stage 50% of my problem is solved.

      I also read the following thread.
      ORA-12547: TNS: lost contact
      either that thread didnot contain the solution i was looking for or I did not understand the thread completely.
      Anyway I was wondering if anyone could provide a new insight into my problem

      I dont know if the Info I provided is sufficient to come up with a solution to my problem, so please ask me If any additional Information is needed and more importantly what information is needed.

      Thank You
        • 1. Re: ORA-12547: TNS:lost contact
          sb92075
          ORA-12547: TNS:lost contact
          getting TNS error when connecting to local DB &
          NOT using SQL*Net, indicates OS/Networking mis-configuration.
          while logged onto DB Server can you successfully ping both hostname & IP#?

          post results of following OS commands

          hostname
          uname -a
          cat /etc/hosts
          • 2. Re: ORA-12547: TNS:lost contact
            Osama_Mustafa
            Refer to
            Troubleshooting ORA-12547 TNS: Lost Contact [ID 555565.1]
            ORA-12547 connecting to sqlplus '/ as sysdba' on AIX [ID 372143.1]
            • 3. Re: ORA-12547: TNS:lost contact
              JohnWatson
              I would start again! Follow the instructions for cloning an Oracle Home, here
              http://docs.oracle.com/cd/E11882_01/install.112/e24332/app_cloning.htm#sthref691
              --
              John Watson
              http://skillbuilders.com
              • 4. Re: ORA-12547: TNS:lost contact
                972227
                Hello Guys, the issue got resolved, The poblem had nothing to do with the oracle home or any oracle permissions. It had everything to do with the semophores owned by root which was causing the problems. So the systems guys bounced the server. they told me about a command ipsc -a which showed the problem. I am still researching on what semophores are and how and what problem it casued on oracle home. But thank you all for your input.