This discussion is archived
1 Reply Latest reply: Feb 9, 2013 6:55 AM by gimbal2 RSS

Having major trouble downgrading from Java 7 to 6

989902 Newbie
Currently Being Moderated
Alright, many of the various applications I use require Java, however, Java 7 has too many issues to even count. I ran Java 6 very well for over a year, until I got a message telling me to update, so I did. Now I can't run hardly anything due to the buggy Java 7. I have uninstalled the JavaAppletPlugin.plugin file, and typed the commands into the terminal (http://support.apple.com/kb/HT5559) and when I do, I get the following:
Command:
sudo mv /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin /Library/Internet\ Plug-Ins/disabled
Outcome:
mv: rename /Library/Internet Plug-Ins/JavaAppletPlugin.plugin to /Library/Internet Plug-Ins/disabled/JavaAppletPlugin.plugin: No such file or directory

This is not letting me downgrade, just making a "Disabled" folder in the "internet plug in" area, and copying and pasting the plugin file. I have been trying to fix this for a week now, and still nothing. Can anyone help?
  • 1. Re: Having major trouble downgrading from Java 7 to 6
    gimbal2 Guru
    Currently Being Moderated
    You should not downgrade but rather remove and reinstall. Java 7 is delivered by Oracle while Java 6 was delivered by Apple; they're two completely different products.

    You should also be more precise; Java 7 works just fine. It is the browser plugins that tend to cause issues especially with the thousand security fixes being applied to them to stop people from hyperventilating thinking there may be security holes in the part of Java that is hardly used.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points