5 Replies Latest reply: Feb 9, 2013 11:39 AM by ranit B RSS

    sql not giving output when run thru sql client

    513158
      Hi all,

      I am facing a very strange problem. When I run a query which is part of PL SQL directly at server through sqlplus I am able to get the output but when I do the same through PL-SQL Developer or by connecting via SQL client the same query gives blank output.

      Please help..

      vip
        • 1. Re: sql not giving output when run thru sql client
          sb92075
          user510155 wrote:
          Hi all,

          I am facing a very strange problem. When I run a query which is part of PL SQL directly at server through sqlplus I am able to get the output but when I do the same through PL-SQL Developer or by connecting via SQL client the same query gives blank output.

          Please help..

          vip
          you have a mystery & we have no clues.

          something is different; but impossible to say exactly what results in different output.

          How do I ask a question on the forums?
          SQL and PL/SQL FAQ


          post COPY & PASTE resuts so we can see exactly what you do & how Oracle responds.

          Handle:     user510155
          Status Level:     Newbie
          Registered:     May 16, 2006
          Total Posts:     46
          Total Questions:     4 (4 unresolved)
          Name     vip
          • 2. Re: sql not giving output when run thru sql client
            ranit B
            user510155 wrote:

            I am facing a very strange problem. When I run a query which is part of PL SQL directly at server through sqlplus I am able to get the output but when I do the same through PL-SQL Developer or by connecting via SQL client the same query gives blank output.
            What is the definition of Strange for you?
            Nothing is strange here... Just coz we don't know the reason doesn't necessarily mean that it is strange.
            select
             rowid, col_1, col_2
            from
             table_x;
            This shows me the rowid properly in SQL*Plus but there's no rowid returned when run in Toad v10.6

            So, please post your query... It might be a client IDE issue.
            • 3. Re: sql not giving output when run thru sql client
              rp0428
              >
              What is the definition of Strange for you?
              Nothing is strange here... Just coz we don't know the reason doesn't necessarily mean that it is strange.

              select
              rowid, col_1, col_2
              from
              table_x;

              This shows me the rowid properly in SQL*Plus but there's no rowid returned when run in Toad v10.6

              So, please post your query... It might be a client IDE issue.
              >
              That's strange! In Toad v9.7.2.5 the rowid IS displayed?
              select rowid, empno, ename, job, mgr from emp where rownum < 3
              
              ROWID     EMPNO     ENAME     JOB     MGR
              AAAR3xAAEAAAACXAAA     7369     SMITH     CLERK     7902
              AAAR3xAAEAAAACXAAB     7499     ALLEN     SALESMAN     7698
              I posted the query in case it might be a client IDE issue. :D
              • 4. Re: sql not giving output when run thru sql client
                Solomon Yakobson
                Let me guess. Your PL/SQL uses DBMS_OUTPUT.PUT_LINE. If so, you need to turn server output on in SQL*Developer. Go to View menu and select Dbms Output. Dbms Output pane will appear. In it there will be a green plus. Click ity and add your connection. Now you'll see dbms_output output.

                SY.
                • 5. Re: sql not giving output when run thru sql client
                  ranit B
                  That's strange! In Toad v9.7.2.5 the rowid IS displayed?
                  select rowid, empno, ename, job, mgr from emp where rownum < 3
                  
                  ROWID     EMPNO     ENAME     JOB     MGR
                  AAAR3xAAEAAAACXAAA     7369     SMITH     CLERK     7902
                  AAAR3xAAEAAAACXAAB     7499     ALLEN     SALESMAN     7698
                  I posted the query in case it might be a client IDE issue. :D
                  Thanks RP... and since last 1.5 yrs of my total 2.5 yrs work exp I've been thinking assuming that Toad never shows rowids
                  (prior to 1.5yr... i didn't even know what a rowid was ;)

                  Thanks that you pointed out... and said that - what can be the proper setting to get that column in 10.6 ??