1 Reply Latest reply: Feb 15, 2013 10:23 PM by Udo RSS

    problem in installing Apex lister

    983057
      hi frnsa when i try to install apex listener 2.0 in windows 7 in gives following errors, please any one can help me?


      C:\Temp>java -jar apex.war
      This Listener instance has not yet been configured.
      Please complete the following prompts

      Enter the location to store configuration data:c:\Temp\temp
      Feb 10, 2013 1:02:26 PM oracle.dbtools.common.config.cmds.ConfigDir execute
      INFO: Set config.dir to c:\Temp\temp in: C:\Temp\apex.war
      null
      java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at oracle.dbtools.jarcl.Entrypoint.main(Entrypoint.java:58)
      Caused by: java.lang.OutOfMemoryError: Java heap space
      at java.util.Arrays.copyOf(Unknown Source)
      at java.io.ByteArrayOutputStream.toByteArray(Unknown Source)
      at oracle.dbtools.common.util.ZipBuilder.build(ZipBuilder.java:63)
      at oracle.dbtools.common.config.cmds.MutatedZip.mutate(MutatedZip.java:4
      2)
      at oracle.dbtools.common.config.cmds.MutatedZip.<init>(MutatedZip.java:1
      5)
      at oracle.dbtools.common.config.cmds.ConfigDir.modified(ConfigDir.java:1
      14)
      at oracle.dbtools.common.config.cmds.ConfigDir.modify(ConfigDir.java:86)

      at oracle.dbtools.common.config.cmds.ConfigDir.execute(ConfigDir.java:68
      )
      at oracle.dbtools.common.cmds.DefaultCommand.configDir(DefaultCommand.ja
      va:50)
      at oracle.dbtools.common.cmds.DefaultCommand.execute(DefaultCommand.java
      :73)
      at oracle.dbtools.common.cmds.Commands.main(Commands.java:91)
      ... 5 more

      C:\Temp>
        • 1. Re: problem in installing Apex lister
          Udo
          Hi,

          could you check whether the java version you use for this call fits to the requirements? Run
          java -version
          If it fits (Java 6 Update 20 JDK or later), try to move your configuration path to a different (preferrably non-temp) location.

          -Udo