3 Replies Latest reply: Feb 11, 2013 10:32 PM by Samdani Gulam RSS

    How to enable debug for weblogic

    967909
      Hi guys

      i would like to enable debug while running weblogic but it is showing an error thea failed to connect to remote vm connection refused error
      please resolve my problem
        • 1. Re: How to enable debug for weblogic
          Rajeev_R
          Are you talking about remote logging using eclipse? Did you make an entry (java options for enabling debug) in startWeblogic.sh file like below?

          set JAVA_OPTS= -Xdebug -Xnoagent
          -Xrunjdwp:transport=dt_socket,address=*8787*,server=y,suspend=n %JAVA_OPTS%

          And you need to add a debug configuration in eclipse with the same port.

          While you starting the server it will display message saying that 'listening to port :8787'

          Please check your configuration.

          Cheers
          R
          • 2. Re: How to enable debug for weblogic
            Nooruddin Shaik
            When u start the weblogic make sure during server startup it displays the option
            Starting WLS with line:
            C:\JDK16~1.0_2\bin\java -Xdebug -Xnoagent -Xrunjdwp:transport=dt_socket,address=3002,server=y,suspend=n

            Note the address port which u need to configure in eclipse.

            If you don't see this java arg in server start up then you need to enable that.
            In <domain>bin/setDomainEnv.bat file add this line in the beginning.
            set debugFlag=true

            The above option is for adminserver and if you are running managedserver then in startWebLogicManagerServer.bat file you need to remove the nodebug option in the end(search for the string).

            Peace
            Shaik
            • 3. Re: How to enable debug for weblogic
              Samdani Gulam
              let us know what steps you followed to configure remote vm for debugging ?
              if you are running on two separate systems then most likely it would be firewall blocking , as per your post " failed to connect to remote vm connection refused error "

              try to configure as per the previous posts by Shaik and Rajeev ,and still if you got issue then please post the steps you followed.