7 Replies Latest reply: Mar 4, 2013 11:01 AM by 990697 RSS

    Workspace 11.1.2.1.0.83 - Change Timeout?

    990697
      Hi,
      I am trying to change the timeout on Workspace (v11.1.2.1.0.83 per the Help | About...) and have followed directions from this thread: Re: Workspace Session Timeout

      After shutting down and restarting the system, testing the timeout shows that it is still at the default 30 minutes (despite checking the settings under Navigate | Administer | Workspace Server Settings and seeing the 60 min it was set to). Checking in Shared Services as this blog indicates (http://rednivhkus.blogspot.ca/2012/05/oracle-epm-auto-logout-time-or-hyperion.html) confirms that the Session Timeout is set to 60 minutes and the Keep-Alive at 10 minutes.

      I also checked my registry settings and tried using the blank reg key to override it but to no avail (plus this route would not be deployed to our end users in any case)

      Is there anything else that could be affecting the timeout on Workspace?

      Thanks!
        • 1. Re: Workspace 11.1.2.1.0.83 - Change Timeout?
          beyerch2
          There are timeouts in the OHS config and IIS configs. I don't think IIS would impact you for workspace, though....

          I have a list I made of all of the settings I had to change to get this to work in 11.1.2.1 as we had a lot of fun with timeouts as there are various settings everywhere. When I get in the office tomorrow, I'll try to add some more specifics.

          Could you confirm the EXACT message users get when they are timeout and do they only get timeout out if in HFM, reports, or both?
          • 2. Re: Workspace 11.1.2.1.0.83 - Change Timeout?
            HFM_CZ
            check this doc: https://support.oracle.com/epmos/faces/ui/km/DocumentDisplay.jspx?id=1110718.1
            • 3. Re: Workspace 11.1.2.1.0.83 - Change Timeout?
              990697
              I will update this with the actual error but it seems like the application is timing out before Workspace itself.


              -------------------
              The error that occurs past 30 minutes is:

              An error has occurred. Please contact your administrator.
              Show Details:
              Error Number:1
              Error Description:Please Relogin. Session has Timed out
              Error Source:
              Page On which Error Occurred:

              I noticed that the actual 'your session is going to timeout' warning and then getting punted back to the login screen happens beyond the 30 minute mark (I have not timed it, but it appears closer to or at the 60minute timeout I had set).

              Edited by: 987694 on Feb 22, 2013 10:45 AM

              Edited by: 987694 on Feb 22, 2013 10:47 AM
              • 4. Re: Workspace 11.1.2.1.0.83 - Change Timeout?
                HFM_CZ
                Yes, the application definitely times out before workspace. When we were on 11.1.1 and the application has timed out we had to close and open it again without logging out from the workspace itself. Now the cool thing about 11.1.2.2 is that it re-opens the application automatically as long as you are not timed out from the workspace
                • 5. Re: Workspace 11.1.2.1.0.83 - Change Timeout?
                  990697
                  Thanks! I haven't yet searched for extending the application timeout -- if you have the details handy can you provide them?
                  • 6. Re: Workspace 11.1.2.1.0.83 - Change Timeout?
                    HFM_CZ
                    Better check all the documents in the link I posted above, but the most basic advice from the Doc 583878.1 is:
                    -----
                    Increase timeout settings for web sessions on the HFM site

                    In normal scenarios, increasing the session timeout might result in performance issues; as more "dead" sessions are kept open much longer, more processing power is wasted on them. To have long session timeouts is also (generally) considered bad practice from a security point of view.
                    Note that these timeouts are only enforced on idle sessions, i.e. when the user will not "click anything" for that amount of time. For this reason, they rarely need to be set to anything higher than 120 minutes.

                    The following instructions change the idle timeout from default 20 minutes to 30 minutes in Microsoft Internet Information Services 6 (IIS):
                    1.Go to Start > All Programs > Administrative Tools > Internet Information Services (IIS) Manager.
                    2.Expand the server node <ServerName> (local computer).
                    3.Right click on the application pool node.
                    4.Select Properties.
                    5.Select the Performance tab.
                    6.Change the Idle timeout value from 20 to 30 minutes.
                    7.Click Apply.
                    8.Click OK.
                    9.Expand the node Web Sites.
                    10.Right click on the 'HFM' web site.
                    11.Go to Properties > Home Directory tab > Configuration button > Options tab.
                    12.Change the Enable session state > Session timeout value from 20 to 30 minutes.
                    13.Click OK.
                    14.Click OK.
                    15.Test that the timeout is now the new value.
                    • 7. Re: Workspace 11.1.2.1.0.83 - Change Timeout?
                      990697
                      Thanks!!!! That did it :)