This discussion is archived
2 Replies Latest reply: Feb 15, 2013 2:11 AM by YTC1 RSS

S11.0 to S11.1 update failure - can't decipher what is needed

YTC1 Newbie
Currently Being Moderated
Its an x86 VB system running S11.0SRU#12.4

I'm going round in circles now trying to work out how to get it to SR11.1 ga

(i can't get at the support repo so need to use the release)

I've done this, as suggested by the upgrade info
---8<
To unlock the packages, run these commands:

# pkg change-facet facet.version-lock.mail/fetchmail=false
# pkg change-facet facet.version-lock.service/network/dns/bind=false
# pkg change-facet facet.version-lock.network/dns/bind=false


Note that it is possible to combine the commands above into one step by specifying the packages on one line:

# pkg change-facet facet.version-lock.mail/fetchmail=false \
facet.version-lock.service/network/dns/bind=false \
facet.version-lock.network/dns/bind=false
---8<

This is the error(s)

Any ideas ? This was a build from S11.0 1111 and has had SRUs applied

---8<
root@ytc-s11-repo:~# pkg update be-name s11.1ga accept
Creating Plan /
pkg update: No solution was found to satisfy constraints
Plan Creation: Package solver has not found a solution to update to latest available versions.
This may indicate an overly constrained set of packages are installed.

latest incorporations:

pkg://solaris/consolidation/admin/admin-incorporation@0.5.11,5.11-0.175.1.0.0.5.0:20111212T232623Z
pkg://solaris/consolidation/l10n/l10n-incorporation@0.5.11,5.11-0.175.1.0.0.23.1134:20120820T154803Z
pkg://solaris/consolidation/cacao/cacao-incorporation@0.5.11,5.11-0.175.1.0.0.11.0:20120305T152551Z
pkg://solaris/consolidation/install/install-incorporation@0.5.11,5.11-0.175.1.0.0.24.1736:20120912T193249Z
pkg://solaris/consolidation/sunpro/sunpro-incorporation@0.5.11,5.11-0.175.1.0.0.19.0:20120625T151735Z
pkg://solaris/consolidation/gfx/gfx-incorporation@0.5.11,5.11-0.175.1.0.0.5.0:20111212T232623Z
pkg://solaris/consolidation/ips/ips-incorporation@0.5.11,5.11-0.175.1.0.0.24.0:20120904T180327Z
pkg://solaris/consolidation/vpanels/vpanels-incorporation@0.5.11,5.11-0.175.1.0.0.17.0:20120529T220223Z
pkg://solaris/consolidation/dbtg/dbtg-incorporation@0.5.11,5.11-0.175.1.0.0.15.0:20120501T214422Z
pkg://solaris/entire@0.5.11,5.11-0.175.1.0.0.24.2:20120919T190135Z
pkg://solaris/consolidation/man/man-incorporation@0.5.11,5.11-0.175.1.0.0.21.0:20120723T163455Z
pkg://solaris/consolidation/desktop/desktop-incorporation@0.5.11,5.11-0.175.1.0.0.24.2:20120919T183843Z
pkg://solaris/consolidation/userland/userland-incorporation@0.5.11,5.11-0.175.1.0.0.24.0:20120904T170613Z
pkg://solaris/consolidation/nspg/nspg-incorporation@0.5.11,5.11-0.175.1.0.0.5.0:20111212T232623Z
pkg://solaris/consolidation/sic_team/sic_team-incorporation@0.5.11,5.11-0.175.1.0.0.5.0:20111212T230120Z
pkg://solaris/consolidation/osnet/osnet-incorporation@0.5.11,5.11-0.175.1.0.0.24.2:20120919T184141Z
pkg://solaris/consolidation/nvidia/nvidia-incorporation@0.5.11,5.11-0.175.1.0.0.22.0:20120806T175117Z
pkg://solaris/consolidation/SunVTS/SunVTS-incorporation@0.5.11,5.11-0.175.1.0.0.14.0:20120416T200729Z
pkg://solaris/consolidation/solaris_re/solaris_re-incorporation@0.5.11,5.11-0.175.1.0.0.24.3:20120919T185316Z
pkg://solaris/consolidation/sfw/sfw-incorporation@0.5.11,5.11-0.175.1.0.0.5.0:20111212T232623Z
pkg://solaris/consolidation/X/X-incorporation@0.5.11,5.11-0.175.1.0.0.24.1317:20120904T175757Z
pkg://solaris/consolidation/desktop/gnome-incorporation@0.5.11,5.11-0.175.1.0.0.22.0:20120806T171142Z
pkg://solaris/consolidation/xvm/xvm-incorporation@0.5.11,5.11-0.175.1.0.0.5.0:20111212T232056Z
pkg://solaris/consolidation/cns/cns-incorporation@0.5.11,5.11-0.175.1.0.0.23.0:20120820T162238Z

The following indicates why the system cannot update to the latest version:

No suitable version of required package pkg://solaris/consolidation/userland/userland-incorporation@0.5.11,5.11-0.175.1.0.0.24.0:20120904T170613Z found:
Reject: pkg://solaris/consolidation/userland/userland-incorporation@0.5.11,5.11-0.175.1.0.0.24.0:20120904T170613Z
Reason: A version for 'incorporate' dependency on pkg:/network/dns/bind@9.6.3.7.2,5.11-0.175.1.0.0.24.0 cannot be found
No suitable version of required package pkg://solaris/consolidation/gnome/gnome-incorporation@0.5.11,5.11-0.151.0.1:20101105T053409Z found:
Reject: pkg://solaris/consolidation/gnome/gnome-incorporation@0.5.11,5.11-0.151.0.1:20101105T053409Z
Reason: A version for 'incorporate' dependency on pkg:/library/python-2/python-notify-26@0.1.1,5.11-0.151.0.1 cannot be found
---8<

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points