This discussion is archived
10 Replies Latest reply: Feb 18, 2013 12:02 AM by Carlo den Otter RSS

EBS R12 database upgrade to 11gR2

maylo Newbie
Currently Being Moderated
Hi All,
I am currently trying to upgrade database to 11gR2 following instruction in 1058763.1. When i try to apply the 6400501 patch (10.1.0.5 version x86), i get this:

OPatch found the word "error" in stderr, please look into it.
You may have to run the make again.
Stderr Output (from /u01/oracle/PROD/apps/tech_st/10.1.2/.patch_storage/6400501/make_local.stderr):
/usr/lib/gcc/x86_64-redhat-linux/4.4.6/32/libgcc_s.so: undefined reference to `__stack_chk_fail@GLIBC_2.4'

collect2: ld returned 1 exit status

make: *** [u01/oracle/PROD/apps/tech_st/10.1.2/rdbms/lib/rman] Error 1

OPatch encounters the following Make issues:
Error for command: cd /u01/oracle/PROD/apps/tech_st/10.1.2//rdbms/lib; /usr/bin/make -f ins_rdbms.mk irman ORACLE_HOME="/u01/oracle/PROD/apps/tech_st/10.1.2" 2>/u01/oracle/PROD/apps/tech_st/10.1.2/.patch_storage/6400501/make_local.stderr
Replying 'Y' will terminate the patch rollback immediately. It WILL NOT restore any updates that have been performed to this point. It WILL NOT update the inventory.
Replying 'N' will continue with updating the inventory showing the patch has been removed.

Do you want to STOP?
Please respond Y|N >
y
Make Error!
ERROR: OPatch failed during patching, possibly due to missing files.


I tried to do the relink:
# unlink /usr/lib/libXtst.so.6
# ln -s /usr/X11R6/lib/libXtst.so.6.1 /usr/lib/libXtst.so.6

But i keep getting the same error. Is there anything else i could try?
Thanks in advance, Maylo

PS.
I am running R12.1.1 with 11.1.0.7.0 on x64 OL6