This discussion is archived
4 Replies Latest reply: Feb 19, 2013 4:16 AM by kamilp RSS

ohasd not starting after fresh install

kamilp Newbie
Currently Being Moderated
Hi,

I have installed Oracle Database 11g Release 11.2.0.1.0 - 64bit Production With the Real Application Clusters and Automatic Storage Management options on SUSE Linux Enterprise Server 11 (x86_64) 11.0.
After installation all cluster and resources were up, I could log in to database. I have restarted orcl1 node, and after boot the ohasd service is not started. Same is with orcl0 node. When I start manually, the cluster comes up. See below:
grid@orcl1:~> crsctl check has
CRS-4639: Could not contact Oracle High Availability Services

orcl1:~ # ps aux | grep ohasd
root      5157  0.0  0.0  11224  1448 ?        Ss   03:02   0:00 /bin/sh /etc/init.d/init.ohasd run
root      5365  0.0  0.0   4316   756 pts/0    S+   03:02   0:00 grep ohasd

orcl1:~ # chkconfig ohasd
ohasd  on

orcl1:~ # service ohasd start
Starting ohasd: 
orcl1:~ #
orcl1:~ # CRS-4123: Oracle High Availability Services has been started.

orcl1:~ # ps aux | grep ohasd
root      5157  0.0  0.0  11224  1464 ?        Ss   03:02   0:00 /bin/sh /etc/init.d/init.ohasd run
root      5414  3.3  0.3 569056 47124 ?        Ssl  03:03   0:01 /u01/app/11.2.0/grid/bin/ohasd.bin reboot
root      5736  0.0  0.0   4316   752 pts/0    S+   03:03   0:00 grep ohasd
Then within short time everything is started up...
Anyone has idea why ohasd service is not started automatically ?


Update:

I have changed /etc/init.d/ohasd file so that it 'logs' to /tmp time when invoked (see below the code). After reboot there is no record of startup /tmp/ohasd*
orcl1:~ # chkconfig --list ohasd
ohasd                     0:off  1:off  2:off  3:on   4:off  5:on   6:off


# This script is invoked by the rc system.
/bin/touch /tmp/ohasd.start."`date`"    # <<<--- added line to 'log' the start
ORA_CRS_HOME=/u01/app/11.2.0/grid
Thanks !

Edited by: kamilp on Feb 17, 2013 11:35 PM
  • 1. Re: ohasd not starting after fresh install
    onedbguru Pro
    Currently Being Moderated
    there should be a line for ohasd in inittab.

    Does this line exist in /etc/inittab:

    h1:35:respawn:/etc/init.d/init.ohasd run >/dev/null 2>&1 </dev/null

    If not, make sure it is added. I have seen where customers use something like "puppet" to keep startup scripts in sync with a "standard" and have had the crs install inittab replaced. just a thought.
  • 2. Re: ohasd not starting after fresh install
    kamilp Newbie
    Currently Being Moderated
    Hi

    like I said above, the the init.ohasd is running
    orcl1:~ # cat /etc/inittab | grep ohasd
    h1:35:respawn:/etc/init.d/init.ohasd run >/dev/null 2>&1 </dev/null
    
    orcl1:~ # ps aux | grep ohasd
    root      5157  0.0  0.0  11224  1448 ?        Ss   03:02   0:00 /bin/sh /etc/init.d/init.ohasd run
    root      5365  0.0  0.0   4316   756 pts/0    S+   03:02   0:00 grep ohasd
     
    I have not replaced anything, just did the fresh install...

    Edited by: kamilp on Feb 18, 2013 1:53 PM
  • 3. Re: ohasd not starting after fresh install
    onedbguru Pro
    Currently Being Moderated
    I do not recall ever having ohasd in chkconfig as it is automatically started from inittab. You may be stomping on yourself. Try removing ot from chkconfig and restarting. How did you stop crs before the reboot? did you disable it?

    How do your ASM devices configured? udev/multipathd/oraclesasm? it could be possible that when chkconfig is trying to start it before the devices are configured... ???
  • 4. Re: ohasd not starting after fresh install
    kamilp Newbie
    Currently Being Moderated
    Hi,

    there are two scripts - both installed by installer, I have not changed anything...
    orcl1:~ # l /etc/init.d/*ohasd*
    -rwxr-xr-x 1 root root 3079 Feb 18 00:37 /etc/init.d/init.ohasd*
    -rwxr-xr-x 1 root root 2632 Feb 18 11:27 /etc/init.d/ohasd*
    
    orcl1:~ # l /etc/init.d/rc5.d/*ohasd*
    lrwxrwxrwx 1 root root 17 Feb 18 00:37 /etc/init.d/rc5.d/S96ohasd -> /etc/init.d/ohasd*
    
    orcl1:~ # head -10 /etc/init.d/ohasd
    #!/bin/sh
    #
    # Copyright (c) 2001, 2009, Oracle and/or its affiliates. All rights reserved.
    #
    # ohasd.sbs  - Control script for the Oracle HA Services daemon
    # This script is invoked by the rc system.
    
    ORA_CRS_HOME=/u01/app/11.2.0/grid
    orcl1:~ # head -10 /etc/init.d/init.ohasd
    #!/bin/sh
    #
    # Copyright (c) 2001, 2009, Oracle and/or its affiliates. All rights reserved.
    #
    # init.ohasd - Control script for the Oracle HA services daemon
    # This script is invoked by the init system

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points