This discussion is archived
2 Replies Latest reply: Feb 26, 2013 6:44 AM by Turbokat RSS

Oracle BI coreapplication down

887005 Newbie
Currently Being Moderated
Hello,

I have a weird problem with the Oracle BI installation and am wondering if anyone can shed some light on it.

I have done two separate installations of Oracle BI on two separate machines. The installation procedure on both was the same:

I have installed Oracle database software and created a listener and a database called orcl.
I have installed (software only) the Oracle BI.
I have created a repository on DB with the rcu utility.
I have configured the BI using ...Middleware/Oracle_BI1/bin/config.sh script

The configuration procedure completed without any errors.

(in both cases the machines had the same configurations)

I created boot.properties for AdminServer and bi_server

Here is where the two installations differ.
After opening http://hostname:7001/em on the first machine, all of the components were up.

On the other machine the coreapplication was down. When I clicked on the link for coreapplication, another window opened and there it showed that all of the 5 components were up, but below there were the following errors:

[nQSError: 43126] Authentication failed: invalid user/password.
Error Message From BI Security Service: [nQSError: 46169] An HTTP operation to 10.10.162.44:9704 timed out after 60 seconds. Operation aborted.
Error while executing job in PollThread.

Also on the left panel of the EM start screen there are 5 components down and 18 components up. Out of the 5 that are down are:

- adminservice
- bioffice
- bipublisher
- bisearch
- mapviewer

To start the services on both systems (the one that works fine and the one that doesn't) I use the following script:

#!/bin/bash

MIDDLEWARE_HOME=...
ORACLE_BI_HOME=...
WLS_HOME=...
BI_DOMAIN_HOME=...
INSTANCE_HOME=...
LOGS=...

export MIDDLEWARE_HOME ORACLE_BI_HOME WLS_HOME BI_DOMAIN_HOME INSTANCE_HOME LOGS

echo "Starting AdminServer ..."

nohup $BI_DOMAIN_HOME/startWebLogic.sh 1>$LOGS/startAS.log 2>$LOGS/startAS.err&

sleep 120

echo "Starting NodeManager ..."

nohup $WLS_HOME/server/bin/startNodeManager.sh 1>$LOGS/snm.log 2>$LOGS/snm.err&

sleep 20

echo "Starting BIServer ..."

nohup $BI_DOMAIN_HOME/bin/startManagedWebLogic.sh bi_server1 t3://localhost.localdomain:7001 1>$LOGS/biserv.log 2>$LOGS/biserv.err&

sleep 120

echo "Starting opmnctl ..."

nohup $INSTANCE_HOME/bin/opmnctl startall 1>$LOGS/opmnctl.log 2>$LOGS/opmnctl.err&

sleep 10

echo "... done"

I have checked the logs for any errors that are outputted from the script but couldn't find any.
The command opmnctl status shows all components online.

Any advise is welcome and appreciated.

Thank you and best regards,
kwhtre

Edited by: 884002 on Feb 19, 2013 4:46 AM
  • 1. Re: Oracle BI coreapplication down
    887005 Newbie
    Currently Being Moderated
    OK that error about invalid username/password: I have found it in sawlog0.log, but that was before I created boot.properties so I suspect that was the reason.
    After that there is no more errors in sawlog0.log Here is the most recent output:

    [2013-02-19T14:02:03.000+01:00] [OBIPS] [NOTIFICATION:1] [] [saw.sawserver] [ecid: 004pXBd6w9RDoYa_xLd9iW0004wm00000F,0] [tid: ] Oracle BI Presentation Services are shutting down.[[
    File:sawserver.cpp
    Line:698
    Location:
         saw.sawserver
    ecid: 004pXBd6w9RDoYa_xLd9iW0004wm00000F,0
    ]]
    [2013-02-19T14:09:05.000+01:00] [OBIPS] [NOTIFICATION:1] [] [saw.sawserver] [ecid: ] [tid: ] Oracle BI Presentation Services (OBIPS) 11.1.1.6.0 (Build 120104.0800 64-bit) are starting up.[[
    File:sawserver.cpp
    Line:451
    Location:
         saw.sawserver
    ecid:
    ]]
    [2013-02-19T14:10:09.000+01:00] [OBIPS] [NOTIFICATION:1] [] [saw.sawserver] [ecid: ] [tid: ] Oracle BI Presentation Services have started successfully.[[
    File:sawserver.cpp
    Line:549
    Location:
         saw.sawserver
    ecid:
    ]]
    [2013-02-19T14:16:44.000+01:00] [OBIPS] [WARNING:16] [] [saw.taskScheduler.processJob] [ecid: 004pXEC0fDqDoYa_xLd9iW0005Zo000000,0:112] [tid: 1091090752] Running task 'Cache/CatalogAttributes' finished in 43355 milliseconds, 10.8% of job's frequency (400 seconds).[[
    File:taskscheduler.cpp
    Line:437
    Location:
         saw.taskScheduler.processJob
         taskscheduler
         saw.threads
    ecid: 004pXEC0fDqDoYa_xLd9iW0005Zo000000,0:112
    ThreadID: 1091090752
    task: Cache/CatalogAttributes
    ]]

    The only log that has any errors is this one:

    nqserver.log:

    [2013-02-19T13:22:48.000+00:00] [OracleBIServerComponent] [NOTIFICATION:1] [] [] [ecid: 004pXB_RWC^DoYa_xLd9iW0004wp000000] [tid: 43911940] Could not connect to the authentication web service (taking OBIS offline) 10.10.162.44: [nQSError: 12002] Socket communication error at call=Connect: (Number=107) Transport endpoint is not connected [[
    [nQSError: 12010] Communication error connecting to remote end point: address = 10.10.162.44; port = 9704.
    [nQSError: 46119] Failed to open HTTP connection to server 10.10.162.44 at port 9704.
    ]]
    [2013-02-19T13:24:48.000+00:00] [OracleBIServerComponent] [NOTIFICATION:1] [] [] [ecid: 004pXB_RWC^DoYa_xLd9iW0004wp000000] [tid: 43911940] Established the connection to authentication web service 10.10.162.44
    [2013-02-19T14:02:12.000+00:00] [OracleBIServerComponent] [ERROR:1] [] [] [ecid: 004pXB_RWC^DoYa_xLd9iW0004wp000000] [tid: 4643c940] [nQSError: 46066] Operation cancelled.
    [2013-02-19T14:02:13.000+00:00] [OracleBIServerComponent] [ERROR:1] [] [] [ecid: 004pXB_RWC^DoYa_xLd9iW0004wp000000] [tid: 4663e940] [nQSError: 46066] Operation cancelled.
    [2013-02-19T14:02:16.000+00:00] [OracleBIServerComponent] [NOTIFICATION:1] [] [] [ecid: 004pXB_RWC^DoYa_xLd9iW0004wp000000] [tid: 1a089cb0] [43031] :     Oracle BI Server shutdown.
    [2013-02-19T14:02:20.000+00:00] [OracleBIServerComponent] [NOTIFICATION:1] [] [] [ecid: 004pXB_RWC^DoYa_xLd9iW0004wp000000] [tid: 1a089cb0] [85008] MDX Member Name Cache subsystem statistics - Entries: 0, Sizes: 0 bytes, Overall Queries: 0, Hits: 0(0%), Misses: 0(0%).
    [2013-02-19T14:02:20.000+00:00] [OracleBIServerComponent] [NOTIFICATION:1] [] [] [ecid: 004pXB_RWC^DoYa_xLd9iW0004wp000000] [tid: 1a089cb0] [85007] MDX Member Name Cache subsystem stopped.
    [2013-02-19T14:02:20.000+00:00] [OracleBIServerComponent] [NOTIFICATION:1] [] [] [ecid: 004pXB_RWC^DoYa_xLd9iW0004wp000000] [tid: 1a089cb0] [58001] Query Cache Statistics -- Hits:0(0%), Qualified Misses:0(0%), Unqualified Misses:0(0%).
    [2013-02-19T14:02:30.000+00:00] [OracleBIServerComponent] [NOTIFICATION:1] [] [] [ecid: ] [tid: 1a089cb0] [14058] Unloaded all subject areas.
    [2013-02-19T14:08:38.000+00:00] [OracleBIServerComponent] [WARNING:1] [] [] [ecid: ] [tid: 78ea4cb0] Warning: Clustering and cache are enabled for this OBIS node, but cluster aware cache is disabled. This can lead to inconsistencies.
    [2013-02-19T14:08:41.000+00:00] [OracleBIServerComponent] [NOTIFICATION:1] [] [] [ecid: 004pXEAOHGSDoYa_xLd9iW0005Zq000000] [tid: 78ea4cb0] [36007] Loading repository /u01/oracle/Middleware/instances/instance1/bifoundation/OracleBIServerComponent/coreapplication_obis1/repository/SampleAppLite_BI0001.rpd.
    [2013-02-19T14:08:44.000+00:00] [OracleBIServerComponent] [NOTIFICATION:1] [] [] [ecid: 004pXEAOHGSDoYa_xLd9iW0005Zq000000] [tid: 435ca940] [14055] Loading subject area: SampleApp Lite ...
    [2013-02-19T14:08:46.000+00:00] [OracleBIServerComponent] [NOTIFICATION:1] [] [] [ecid: 004pXEAOHGSDoYa_xLd9iW0005Zq000000] [tid: 435ca940] [14056] Finished loading subject area: SampleApp Lite.
    [2013-02-19T14:08:46.000+00:00] [OracleBIServerComponent] [NOTIFICATION:1] [] [] [ecid: 004pXEAOHGSDoYa_xLd9iW0005Zq000000] [tid: 78ea4cb0] [58002] Query Cache loaded with 0 entries from saved cache files.
    [2013-02-19T14:08:46.000+00:00] [OracleBIServerComponent] [NOTIFICATION:1] [] [] [ecid: 004pXEAOHGSDoYa_xLd9iW0005Zq000000] [tid: 78ea4cb0] [85003] MDX Member Name Cache subsystem started successfully.
    [2013-02-19T14:08:46.000+00:00] [OracleBIServerComponent] [NOTIFICATION:1] [] [] [ecid: 004pXEAOHGSDoYa_xLd9iW0005Zq000000] [tid: 78ea4cb0] [85004] MDX Member Name Cache subsystem recovered entries: 0, size: 0 bytes.
    [2013-02-19T14:08:46.000+00:00] [OracleBIServerComponent] [ERROR:1] [] [] [ecid: 004pXEAOHGSDoYa_xLd9iW0005Zq000000] [tid: 78ea4cb0] [13026] Error in getting roles from BI Security Service: 'Error Message From BI Security Service: [nQSError: 12002] Socket communication error at call=Connect: (Number=107) Transport endpoint is not connected [[
    [nQSError: 12010] Communication error connecting to remote end point: address = 10.10.162.44; port = 9704.
    [nQSError: 46119] Failed to open HTTP connection to server 10.10.162.44 at port 9704.'
    ]]
    [2013-02-19T14:08:46.000+00:00] [OracleBIServerComponent] [ERROR:1] [] [] [ecid: 004pXEAOHGSDoYa_xLd9iW0005Zq000000] [tid: 78ea4cb0] [13037] Cannot connect to BI Security Service, please make sure this is running properly (with SSL or not) in EM.
    [2013-02-19T14:08:47.000+00:00] [OracleBIServerComponent] [NOTIFICATION:1] [] [] [ecid: 004pXEAOHGSDoYa_xLd9iW0005Zq000000] [tid: 78ea4cb0] nqsserver:     Clustered Oracle BI Server (64-bit) started. Version: 11.1.1.6.0.120104.1053.000.
    [2013-02-19T14:08:50.000+00:00] [OracleBIServerComponent] [NOTIFICATION:1] [] [] [ecid: 004pXEAOHGSDoYa_xLd9iW0005Zq000000] [tid: 467fc940] [43071] A connection with Cluster Controller orabi.bidomain:9706 was established.
    [2013-02-19T14:08:57.000+00:00] [OracleBIServerComponent] [NOTIFICATION:1] [] [] [ecid: 004pXEAOHGSDoYa_xLd9iW0005Zq000000] [tid: 43bd0940] Could not connect to the authentication web service (taking OBIS offline) 10.10.162.44: [nQSError: 12002] Socket communication error at call=Connect: (Number=107) Transport endpoint is not connected [[
    [nQSError: 12010] Communication error connecting to remote end point: address = 10.10.162.44; port = 9704.
    [nQSError: 46119] Failed to open HTTP connection to server 10.10.162.44 at port 9704.
    ]]
    [2013-02-19T14:11:39.000+00:00] [OracleBIServerComponent] [NOTIFICATION:1] [] [] [ecid: 004pXEAOHGSDoYa_xLd9iW0005Zq000000] [tid: 43bd0940] Established the connection to authentication web service 10.10.162.44


    The problem still persists, so that invalid username/password had no correlation to the problem obviously.
    There is one thing that is different between the two servers I have used to test Oracle BI . The one that runs without any problems has better hardware than the one where coreappliaction is down.

    The one that is fine: 6GB RAM; 6GB swap; i7 processor
    The one that is not fine: 2GB ram; 4GB swap; i3 processor

    Both machines are also running an Oracle DB additional to Oracle BI.

    Could it be at all possible that the reason is hardware related. Anyone ?

    Br,
    kwhtre

    Edited by: 884002 on Feb 19, 2013 5:29 AM
  • 2. Re: Oracle BI coreapplication down
    Turbokat Pro
    Currently Being Moderated
    Hello,

    This is the problem with DHCP configuration for OBIEE components to communicate thru TCP/IP. Please refer to this post and you should be able to fix this problem.

    http://www.rittmanmead.com/2012/08/obiee-fmw-and-networking-on-dhcp-hosts/

    Hope this helps. Pls mark if it does.

    Thanks,
    SVS

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points