2 Replies Latest reply: Feb 19, 2013 9:25 AM by bcomer RSS

    Properties in JNLP resources

    970271
      I'm starting a desktop Swing app using JWS on a Linux box. The .jnlp load some system properties in the resource section:

      <resources>
      <j2se version="1.6+" />
      <property name="sid" value="8FF565C47057D865CBA4D1FCB5BDC7D6"/>
      <property name="serviceHost" value="localhost"/>
      <property name="servicePort" value="8080"/>
      <jar href="app/Webtyper.jar" />
      </resources>

      Everything loads OK using java-7-oracle/jre/bin/javaws but using jdk1.6.0_35/bin/javaws the properties don't seem to be loading. Any thoughts on what's going on?

      The case that works:

      Java Web Start 10.9.2.05
      Using JRE version 1.7.0_09-b05 Java HotSpot(TM) 64-Bit Server VM

      The case that fails to set the properties:

      Java Web Start 1.6.0_35
      Using JRE version 1.7.0_09-b05 Java HotSpot(TM) 64-Bit Server VM

      Edited by: rkepler on Nov 15, 2012 9:45 AM
        • 1. Re: Properties in JNLP resources
          bcomer
          Have you determined any solution for this issue?
          • 2. Re: Properties in JNLP resources
            bcomer
            Below is a known issue with 6u37 (not sure if it applies to your issue):

            Area: deploy/webstart
            Synopsis: Regression - Issue in parsing jvm args for Java Web Start relaunch on Unix platforms.

            Some combinations of java-vm-args and <property> elements in a jnlp file may cause some properties to be set incorrectly when Java Web Start is forced to relaunch. The problem is applicable to Solaris and Linux platforms.

            In some cases, adding dummy property elements to the jnlp file may help prevent the problem.