3 Replies Latest reply on Feb 19, 2013 6:13 PM by 991721

    DRG-11225: Third-party filter timed out


      I am facing the following problem when indexing a column:

      DRG-11207: user filter command exited with status 2
      DRG-11225: Third-party filter timed out.

      I am using Ubuntu 10.04.2 LTS and Oracle Database 11g Enterprise Edition Release

      I have a column named URL in a table named DOCUMENTO_CONSULTA
      This column contains file URLs (2 rows involved in the test)
      I am confident that the paths that appear in the two rows of the URL column are correct (because if I change
      them to something different another error appear that says, as expected, that files could not be found). I am sure
      that access to the files is granted. FILE_ACCESS_ROLE is set to CTXAPP and role is granted to the user. File
      and path permission are set to 777.
      The two rows contains paths to simple DOC and PDF content, with just one paragraph each.

      I am using the following configuration:

      ctx_ddl.create_preference ('ajn_doc_cons_datastore', 'URL_DATASTORE');
      ctx_ddl.set_attribute ('ajn_doc_cons_datastore', 'urlsize', 1024);

      ctx_ddl.create_preference ('ajn_doc_cons_filter', 'AUTO_FILTER');
      ctx_ddl.set_attribute ('ajn_doc_cons_filter', 'timeout', 0);

      ctx_ddl.create_preference ('ajn_spanish_lexer', 'BASIC_LEXER');
      ctx_ddl.set_attribute ('ajn_spanish_lexer', 'base_letter', 'YES');
      ctx_ddl.set_attribute ('ajn_spanish_lexer', 'index_themes', 'NO');
      ctx_ddl.set_attribute ('ajn_spanish_lexer', 'index_stems', 7);
      ctx_ddl.set_attribute ('ajn_spanish_lexer', 'index_text', 'YES');

      ctx_ddl.create_preference ('ajn_spanish_wordlist', 'BASIC_WORDLIST');
      ctx_ddl.set_attribute ('ajn_spanish_wordlist', 'stemmer', 'SPANISH');
      ctx_ddl.set_attribute ('ajn_spanish_wordlist', 'fuzzy_match', 'SPANISH');

      The sentence to create the index is:

      create index ajn_doc_cons_idx on documento_consulta(URL)
      indextype is ctxsys.context
      parameters ('LEXER ajn_spanish_lexer DATASTORE ajn_doc_cons_datastore FILTER ajn_doc_cons_filter WORDLIST ajn_spanish_wordlist ')

      I've tried changing URL_DATASTORE to FILE_DATASTORE (with no attributes) but the result is the same

      Here's the configuration I've set in /etv/environment:

      ORACLE_HOSTNAME=--------- (my host name)

      If I try to use ctxhx from the console everything works OK and twoHTML files corresponding to the two rows are generated with no errors at all.

      I haven't found any relevant information in forums and docs. I don't have any more ideas, so any answer would be appreciated.

      Thanks in advance

      Edited by: 988718 on 18-feb-2013 7:16
        • 1. Re: DRG-11225: Third-party filter timed out
          I've simplified the creation of the index to this:

          create index ajn_doc_cons_idx on documento_consulta(URL) indextype is ctxsys.context parameters ('DATASTORE ctxsys.file_datastore FILTER ctxsys.auto_filter')

          And of course I've change the URL of the columns to paths in the filesystem. Paths are ok.

          Problem keeps happening.
          • 2. Re: DRG-11225: Third-party filter timed out
            Roger Ford-Oracle
            Ubuntu is not a supported platform for Oracle, so it's hard to answer this.

            However, if you want to try to debug it, replace the "ctxhx" executable with a shell script which dumps its arguments and the current environment to a file.

            You can then use that output to create a shell with the same environment, and see if command line ctxhx still works. If not, you'll have to figure out what the differences are between the two environments.
            • 3. Re: DRG-11225: Third-party filter timed out
              I don't know how to do that, I'm a newbie, but I understand that help about this topic is beyond the scope of this thread.
              Anyway, I tried the same scenario (Oracle version, database, parameters, index...) in Fedora 17 and it worked,
              so I guess that the settings are ok and the problem is located in the link between Ubuntu and Oracle (or maybe I did a
              bad Oracle installation).

              Thank you very much.