This discussion is archived
12 Replies Latest reply: Feb 21, 2013 2:55 AM by 979405 RSS

OBIEE Configuration Issue - unable to start BI Components

979405 Newbie
Currently Being Moderated
I am facing issue in restarting BI server components. I have installed oracle database EE 11gr2 and after creating repository, installed OBIEE 11g successfully. After that I have created sample application and uploaded the .rpd file in weblogic server also. but when i am trying to restart the BI server components, I am getting error saying ' All 5 components are down'. any obiee experts or pointer will be of great help
  • 1. Re: OBIEE Configuration Issue - unable to start BI Components
    Vineeth.K.M Journeyer
    Currently Being Moderated
    Hi,

    Please look into the log files.
    That should give u a head start!

    Thanks,
    Vineeth
  • 2. Re: OBIEE Configuration Issue - unable to start BI Components
    878994 Newbie
    Currently Being Moderated
    Hi Karthi,

    There is also another work around. please deploy the Sample AppLite RPD again in the weblogic server. And try restarting, if the weblogic restarts without any issues then the problem may lie in your newly created RPD.

    Thanks
    Thenmozhi.
  • 3. Re: OBIEE Configuration Issue - unable to start BI Components
    979405 Newbie
    Currently Being Moderated
    hi vineeth,

    I couldn't figure out from log files. could you please tel me which log file i should refer?
  • 4. Re: OBIEE Configuration Issue - unable to start BI Components
    979405 Newbie
    Currently Being Moderated
    hi thenmozhi,

    I tried that. still then all the components are down. unable to to make it 'up' after restarting also. I am using windows 7 32 bit OS machine and it is stand alone machine. Is this issue related to system configuration?
  • 5. Re: OBIEE Configuration Issue - unable to start BI Components
    850904 Explorer
    Currently Being Moderated
    Hi Karthik,

    Look for logs in the following location:

    OBIEE_HOME\instances\instance1\diagnostics\logs

    Under the above folder, you can check the logs for individual obiee components. Post the error messages for each component

    Thanks,
    Arul
  • 6. Re: OBIEE Configuration Issue - unable to start BI Components
    979405 Newbie
    Currently Being Moderated
    Arul,

    Thanks for the info. just explored the log files. under the path for all the components there are so many log files.
    Anyway Through Enterprise Manager Diagnostics, the following is the error message:

    SEVERE: Element Type: DOMAIN, Element Id: null, Operation Result: FAILED_TO_SAVE_CREDENTIALS, Detail Message: null

    Operation Failed: stop; OracleInstance: instance1;
    Component: coreapplicationobisch1_; msg: could not get socekt for host xxxxxxxxx.com and port: 9501. The remote OPMN server is probably not running or the OPMN mbean is not properly configured. see the adminserver log for more details.

    Operation Failed: stop; OracleInstance: instance1;
    Component: coreapplicationobips1_; msg: could not get socekt for host xxxxxxxxx.com and port: 9501. The remote OPMN server is probably not running or the OPMN mbean is not properly configured. see the adminserver log for more details.

    Operation Failed: stop; OracleInstance: instance1;
    Component: coreapplicationobijh1_; msg: could not get socekt for host xxxxxxxxx.com and port: 9501. The remote OPMN server is probably not running or the OPMN mbean is not properly configured. see the adminserver log for more details.

    Operation Failed: stop; OracleInstance: instance1;
    Component: coreapplicationobiccs1_; msg: could not get socekt for host xxxxxxxxx.com and port: 9501. The remote OPMN server is probably not running or the OPMN mbean is not properly configured. see the adminserver log for more details.

    Edited by: Karthik K on Feb 21, 2013 9:49 AM
  • 7. Re: OBIEE Configuration Issue - unable to start BI Components
    Vineeth.K.M Journeyer
    Currently Being Moderated
    Hi,

    Since you have created a new RPD and uploaded it and the services are down post uploading,
    The problems might be with the RPD.
    Open the RPD in offline mode, and do a global consistency check (cntrl K). Please make sure that there are no errors.
    Once the RPD is consistent, please check if the connection pool is valid. i.e right click on a table and select view data.
    If the data is retrieved, there is no problem with the RPD.
    Then, move on to the log files...
    You can check the BI server component log to start with . The file name is NQServer.log.

    Thanks,
    Vineeth
  • 8. Re: OBIEE Configuration Issue - unable to start BI Components
    979405 Newbie
    Currently Being Moderated
    Hi vineeth,

    I have check with my rpd files. It is proper as yu told i checked for all the consistency. Moreover i tired with sample app lite rpd also. I can tell you there is no problem with rpd files. uploaded in web logic server and while applying changes i got the error mentioned above.
    I think there is problem with connection socket only. as mentioned in above msg posts for each BI components.

    Thanks,
    Karthik
  • 9. Re: OBIEE Configuration Issue - unable to start BI Components
    Satya Ranki Reddy Expert
    Currently Being Moderated
    Hi,

    I can suggest you please follow the below steps.

    1. Clear the browse cookies and temp files.

    2. deploy the SampleAppLite.rpd(oracle provided).

    3. When I deploy new RPD and Catalog, the user weblogic was not able to login. So I modified the NQSConfig.INI file to make the below change
    FMW_UPDATE_ROLE_AND_USER_REF_GUIDS = YES

    and restarted the BI Servers

    4. open the instanceconfig file add the below tag.

    <UpdateAccountGUIDs>none</UpdateAccountGUIDs>

    then restart the services

    If still issue occured please refer this thread.

    BI server is not starting when deploying upgraded RPD

    Hope this help's

    Thanks,
    Satya
  • 10. Re: OBIEE Configuration Issue - unable to start BI Components
    Vineeth.K.M Journeyer
    Currently Being Moderated
    Hi,

    Pls follow the below steps:

    1. Upload Sample APP RPD. Restart the services.Make sure all services are up and running.
    2.Since the RPD is consistent and also assuming that the new RPD was developed on the same server, GUID should not be a problem.
    Did u right click on the table in the physical layer of the RPD and select view data ?
    If it shows a communication failed, this might be the reason.
    you will have to add the TNS file in the OBIEE install location:
    <install drive>:\Middleware\Oracle_BI1\network\admin
    and restart the BI services, which includes the weblogic server. Preferably, restart using STOP BI services and Start BI services menu under ALL PROGRAMS>ORACLE BUSINESS INTELLIGENCE.
    After this activity, see if you are able to see the data in the RPD physical Layer and then upload the RPD and restart the services.

    Thanks,
    Vineeth
  • 11. Re: OBIEE Configuration Issue - unable to start BI Components
    979405 Newbie
    Currently Being Moderated
    hi vineeth,

    thanks for the response.

    yes i followed all your steps. everything is fine.
    after verifying rpd file, i have uploaded in web logic server.
    but when i try to restart the changes . all the components are down.
    And I am getting the error log as above.

    I have dropped a mail to ur personal id. please reply to that.

    Thanks,
    Karthik
  • 12. Re: OBIEE Configuration Issue - unable to start BI Components
    979405 Newbie
    Currently Being Moderated
    Hi Satya,

    Thanks for the response.

    I tried what you have mentioned first step.
    but donno to locate these file,.

    +4. open the instanceconfig file add the below tag.+

    can you please tell me file name and its location.

    Thanks,
    Karthik

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points