2 Replies Latest reply: Feb 20, 2013 1:47 PM by CraigB RSS

    Object library changes not recognised

    923563
      I opened Object library uvobj.olb
      Dragged this olb into a new form and choose copy
      Made modification changed the call_form code to call another form in when button pressed trigger.
      Copied this trigger back to Object Library in the new form
      and copied then copied object library to original olb file
      Saved this olb file.
      Deployed this to server and compiled a form.
      But the change is not seen in the form..

      Tried the same steps with subclass option.
      As soon as I subclass the other triggers from the form get removed.

      Please advise the steps to change WhenButtonpressed trigger in OLB file.
        • 1. Re: Object library changes not recognised
          HamidHelal
          I'm not clear with your text. and what is your form version ?
          One suggestion
          Open the uvobj.olb and make your changes then save.
          then subclass and check.

          Hope this helps
          • 2. Re: Object library changes not recognised
            CraigB
            After you updated your Object Library (.olb) did you copy your object group to a test form to ensure your changes were there? I have found the editing of an Object Library to be a little kludgy. The most effective way I have found to update an Object Library is to copy the Object group to a form. Make the necessary changes, then delete the original Object Group in the .olb and then copy the Object Group from the form back to the Object Library (.olb) file. There's probably a better way to do this, but this is what has worked consistently for me.

            Hope this helps,
            Craig...