4 Replies Latest reply: Oct 17, 2013 5:35 AM by c9ae45d2-e9ab-4aff-9b35-353b78faa36a RSS

    Error "JavaScript is required. Enable Javascript to use OAM server"

    User800420-Oracle
      Hi, I use a BeehiveOnline workspace to share documents with my customer. However, when they want to open the documents, some of them get the error "JavaScript is required. Enable Javascript to use OAM server" -can anyone let me know how to fix that? I don't have any issues with the document, and it does not happen to all people at the customer's site....
      Thanks in advance,
      Mette
        • 1. Re: Error "JavaScript is required. Enable Javascript to use OAM server"
          pbell
          Mette,

          Looks like an individual browser setting causing the message. OAM has been known to hit thisa problem with FF but not IE in most cases.

          The reason for the error report in technical terms is:

          The problem occurs because the /oam/server/auth_cred_submit request returns a response containing Javascript. This Javascript builds a form that submits to the Failure URL using POST method. The Response also includes a check to verify if JS is enabled. If not, it will display the message 'Javascript is required...' to the user and processing will stop.

          there is a fix in a later version of OAM so we will eventually upgrade away from the problem. Unfortunately, we don't control the OAM service - we are just customers.

          Phil
          • 2. Re: Error "JavaScript is required. Enable Javascript to use OAM server"
            User800420-Oracle
            Thanks a lot Phill for your quick response, it is very much appreciated.
            Kind regards,
            Mette
            • 3. Re: Error "JavaScript is required. Enable Javascript to use OAM server"
              GavinWoods
              Hi,

              We had a customer that ran into the same exact issue and symptoms described in this thread. The issues occurred after some upgrades were made to their browsers. Our customer was using Forms/Reports 11.1.2.1 (11gR2), and OAM (11.1.1.5). I'm not sure what version of OAM you are currently using?

              The issue was caused by a bug in OAM 11.1.1.5. The problem is exactly as pbell was explaining. By looking at the failed HTML/Javascript code generated by OAM - it was just poorly generated code by OAM. However, Install Bundle Patch 2 (BP02) onto OAM and you'll be fine! This updates your OAM to version 11.1.1.5.2.


              Oracle Support documents on the issue and bug:
              - There is a Oracle Support article describing the issue: 1447194.1
              - Oracle Support Bug Number: 13254371

              To fix the issue:
              - Apply OAM Patch: 13115859. Its a generic patch that will work on any environment type.
              - If you use WebGates for your deployment, look into install patch 13453929 as well

              I wrote an article on how to install the patch: http://pitss.com/us/2013/04/04/oam-error-enable-javascript-to-use-oam-server/

              I hope this helps!

              Thank you,

              Gavin

              Edited by: GavinWoods on Apr 5, 2013 9:29 AM
              • 4. Re: Error "JavaScript is required. Enable Javascript to use OAM server"
                c9ae45d2-e9ab-4aff-9b35-353b78faa36a

                Hi Mette,

                I got the same error, and I used Google Chrome and it worked.

                Regards,

                Vinod