4 Replies Latest reply: Feb 24, 2013 11:33 PM by CH.ADITYA RSS

    Proxy service disable problem in OSB

    CH.ADITYA
      Hi All,

      I have two proxy services in a OSB project (one with OWSM policy and other without OWSM policy applied to it). Apart from this the two proxy services are implemented in the exactly same way. When I disable the proxy service to which OWSM policy is attached, and when I click the WSDL of the disabled proxy in browser it is automatically being redirected to the wsdl of other proxy service which doesn't have OWSM policy attached to it. I don't understand how it's happening. The only reason that I could think of is namespace of wsdl's which is different for both proxies (one has http://company.com/service and other is http://company.com/service/). Can anybody explain this issue?

      Adi
        • 1. Re: Proxy service disable problem in OSB
          CH.ADITYA
          I have observed one thing:

          The endpoint for service (without OWSM) is: B2B/Gateway
          The endpoint for service (with OWSM) is: B2B/Gateway/Legacy

          So when I change the endpoint of service (with OWSM) to B2B/Legacy (removed Gateway), then it is not causing any problem.

          Can anybody pls explain this?
          • 2. Re: Proxy service disable problem in OSB
            Anuj Dwivedi--Oracle
            Looks like a bug to me. Raise a SR with support and if they confirm it as a bug then you will get a fix for it.

            Regards,
            Anuj
            • 3. Re: Proxy service disable problem in OSB
              vladodias
              when I click the WSDL of the disabled proxy in browser it is automatically being redirected to the wsdl of other proxy service which doesn't have OWSM policy attached to it
              Not sure if I understand the problem properly, but how did you observe this? Did the URL change or just the content? Are you sure that's not a browser's cache issue?
              • 4. Re: Proxy service disable problem in OSB
                CH.ADITYA
                Vlad,

                The URL is same, but the content from the wsdl of Proxy service which doesn't have OWSM policy attached to it. Ideally it should display 404 error when the proxy is disabled, but on the contrary it is displaying the content of other Proxy service which has endpoint similar to this.

                The only difference in the endpoints between the two services is:
                Proxy with OWSM: B2B/Gateway/Legacy
                Proxy without OWSM: B2B/Gateway

                I've cleared the cache memory in IE. Even asked other's to open it in their systems.

                Thanks,
                Adi