1 Reply Latest reply: Feb 22, 2013 3:46 PM by Gary Graham-Oracle RSS

    Java 6 EOL, Java 7 not certified

    992825
      After February 2013, Oracle will no longer post updates of Java SE 6, and SQL Developer does not support Java 7.
      When can we expect patch/new version fixing Java 7 problems?

      Running Windows 7 Enterprise/32 bit.
      SQL Developer 3.2.20.09 MAIN-09.78
        • 1. Re: Java 6 EOL, Java 7 not certified
          Gary Graham-Oracle
          Hi,
          When can we expect patch/new version fixing Java 7 problems?
          That would be 3.2.20.09.87, the latest production release, even though the warning dialog is still displayed. Are there any specific issues you have encountered that you wish to report? I believe all the issues we knew about through October 2012 were fixed. There was even some issue that caused us to rev-up the version of Java 6 shipped with the larger 32-bit download to jdk1.6.0_35.

          Anyway, there is no official change yet to our recommendation regarding which version of the JDK to use, but you can find references on this forum stating that 3.2.20.09.87 plays well with Java 7:
          Re: Unable to run SQL Developer
          Re: java.exe Requirement to run SQL Developer?

          The next release, currently still under development, compiles fine both with Java 6 (officially) and Java 7 (unofficially), and I personally have been using Java 7 when developing and testing for several months now.

          Regards,
          Gary
          SQL Developer Team