2 Replies Latest reply: Feb 25, 2013 6:09 AM by Andres Vilallave RSS

    Error importing 4.1 workspace on apex 4.2.1.

    Andres Vilallave
      Hi, i recently installed apex 4.2.1. I can login on internal workspace with admin, all ok, but i get errors by importing my old workspace (4.1).
      I have loaded the exported sql in TOAD to get better error log. Here it is:



      Error at line 36
      ORA-06502: PL/SQL: error numérico o de valor
      ORA-06512: en "SYS.OWA_UTIL", línea 356
      ORA-06512: en "SYS.HTP", línea 1368
      ORA-06512: en "SYS.HTP", línea 1443
      ORA-06512: en "SYS.HTP", línea 1735
      ORA-06512: en "APEX_040200.WWV_FLOW_ERROR", línea 154
      ORA-20987: Unauthorized access (security group package variable not set).
      ORA-06512: en "APEX_040200.WWV_FLOW_ERROR", línea 613
      ORA-06512: en "APEX_040200.WWV_FLOW_ERROR", línea 903
      ORA-06512: en "APEX_040200.WWV_FLOW_FND_USER_API", línea 135
      ORA-06512: en "APEX_040200.WWV_FLOW_FND_USER_API", línea 1372
      ORA-06512: en línea 2

      "Unauthorized access (security group package variable not set)" Is it the cause?

      I try to import the workspace on a exisiting schema, the same where i installed apex.

      I can create the workspace manually and next, import the aplications, but i lose the groups and users.


      Edited by: Andres Vilallave on 25-feb-2013 10:04

      Edited by: Andres Vilallave on 25-feb-2013 10:05
        • 1. Re: Error importing 4.1 workspace on apex 4.2.1.
          Joni Vandenberghe
          You seem to be getting an error on your workspace id, I'm guessing you tried to create it manually first.

          So instead of creating a new workspace you need to do an update of your manually created workspace.
          That's ok you can create it manually first, Ill describe here how you can update it.

          First go to the view APEX_WORKSPACES in your APEX 4.1 schema in the database. Find out what the workspace ID is in your database.

          Copy the ID and then open your workspace sql file (that you import).
          Go to the line:

          begin
          wwv_flow_api.set_security_group_id(p_security_group_id=>XXXXX);
          end;

          Replace XXX with your workspace id.

          Import the file.
          • 2. Re: Error importing 4.1 workspace on apex 4.2.1.
            Andres Vilallave
            Hummm. i don't understand...
            The workspace id on the sql file is already like the apex workspace view on 4.1.
            Also, If i create the workspace before, i can't import the file...