6 Replies Latest reply: Jun 3, 2013 4:57 AM by Feri RSS

    hide dimension in data form also hide the data

    Feri
      Hi all,

      It might sound simple, but i still could not found a workaround for this problem.

      so here is the problem:

      1. example i have dimension lineItem with member line1, line2, line3

      FY13
      Jan | Feb | ...
      line1 | 1 | 1
      line2 | 2 | 2
      line3 | 3 | 3

      2. i want to hide the line information so i choose to hide dimension for dimension LineItem. but instead hiding the dimension, it hide all the row (so no data shown).

      3. i try to hide dimension that is used as column but everything is fine as the following:

      FY13
      line1 | 1 | 1
      line2 | 2 | 2
      line3 | 3 | 3

      Anyone have this experience or method about how to hide dimension in row but still keep the data?
      (i'm using hyperion 11.1.2.2)


      Best Regards,
      Feri
        • 1. Re: hide dimension in data form also hide the data
          921550
          Hi,

          From what I understand is that you have only one dimension in Row and you are trying to hide it.

          This won't work as you need at least one more dimension in row so that data is displayed in the intersection of this dimension with column dimension.

          You would need to add one more dimension in row and the hide then LineItem dimension.

          Your columns have two dimensions, one seems to be Period and other seems to be Year. So hiding period dimension in columns is working fine with you as year dimension is still available in column for representing the data.

          Hope this helps.

          Regards
          -SM
          • 2. Re: hide dimension in data form also hide the data
            Feri
            Hi SM,


            Thank you for your help, actually i have another dimension in row as the following:

            FY13
            Jan | Feb | ...
            new sales | product A l line1 | 1 | 1
            l line2 | 2 | 2
            l line3 | 3 | 3

            i already test it again and i get the following result:
            1. if i only have 2 dimension in row: product and LineItem (hidden) i get the following:

            FY13
            Jan | Feb | ...
            product A | 1 | 1
            product A | 2 | 2
            product A | 3 | 3

            (it work fine)

            2. if i have 3 or more dimensions in row, i get the following:

            FY13
            Jan | Feb | ...
            new sales | product A | 1 | 1

            (it only show one row which is the line1, it seems like it cannot handle if we put more dimensions)

            Edited by: Feri on Feb 27, 2013 3:12 AM
            • 3. Re: hide dimension in data form also hide the data
              921550
              Hi,

              Do you mean you have data in New sales->Product A->Line2-> Jan as 2 which is not visible when you hide line dimension ?

              I created the same scenario and it is still working fine with me. I am on 11.1.2.1.

              Regards,
              -SM
              • 4. Re: hide dimension in data form also hide the data
                Feri
                Hi SM,

                after you mention about version, i try to test on 11.1.2.1 in a different server and then it work fine!

                ohhh i guest 11.1.2.2 got too many bug,
                if you have any information about patch or try in 11.1.2.2 please please help, many thanks SM.
                • 5. Re: hide dimension in data form also hide the data
                  921550
                  Hi,

                  I checked the same on 11.1.2.2.300 version and it too is working fine.

                  Is there sometime which is not usual with this web form?

                  Regards,
                  -SM
                  • 6. Re: hide dimension in data form also hide the data
                    Feri
                    Hi,
                    I'm very sorry that i just reply it now. i already try to patch to 303 but still have the problem.

                    Then we try to post this issue to oracle support, and then they said that they can replicate this problem and said this is a new bug.
                    So now we just wait for them to release a new patch to solve this issue.

                    Thanks.