2 Replies Latest reply: Feb 28, 2013 10:36 AM by ssondere RSS

    SQL History -- won't display

      I love SQL Developer. I love the SQL History feature.

      However, I'm distraught. Recently, the SQL History stopped loving me back. It just won't display -- either from F-8 or from the View menu. From what I can tell, it looks like the history files are still being written. I've looked through all of my settings and can't see anything amiss.

      I could really use some help if anyone knows the magic word to make my History reappear.

        • 1. Re: SQL History -- won't display
          Jeff Smith Sqldev Pm-Oracle
          Hopefully it's the windowing layout settings that's messed up.

          Shutdown sqldev

          Find this file

          C:\Users\\AppData\Roaming\SQL Developer\system3.\o.ide.\windowinglayout.xml Just exit SQL Developer, ...

          Delete it

          Re-open SQLDev and try again.

          If it still doesn't work, it's mostly like due to the history index being corrupted - it's trying to reference a history item (file) that doesn't exist.

          You could try running SQLDev and capturing the console output to see what's going wrong - see the sticky note at the top of the forums for directions on doing this.
          • 2. Re: SQL History -- won't display
            I closed SQL Developer.

            Deleted C:\Documents and Settings\<me>\Application Data\SQL Developer\system3.\o.ide.\windowinglayout.xml (sorry, I should have mentioned that I'm stuck in XP).

            Still no love. I opened SQL Developer and still can't see the SQL History, either through F-8 or through the View menu. It just ignored me. It's like it just doesn't care anymore :)

            No messages in the console window. Again, I felt so ignored.....

            So, I looked at the possibility of a history files/indexes being bad. Since I don't totally know how it works, I just guessed based on file and directory names. There's not much to lose at this point, so why not?

            I deleted all of the files in C:\Documents and Settings\<me>\Application Data\SQL Developer

            I also cleaned out all of the files in all of the directories under C:\Documents and Settings\<me>\Application Data\SQL Developer\system3.\.history

            I may not have needed to do both steps (I got impatient), but that did the trick!! SQL History loves me again!!

            Thanks for putting me on the right path.


            Edited by: ssondere on Feb 28, 2013 8:35 AM