This discussion is archived
3 Replies Latest reply: Feb 27, 2013 1:44 PM by JuliánIsaza RSS

Cohost JavaEE apps with OSB?

739930 Newbie
Currently Being Moderated
For testing purposes im trying to cohost my javaee apps on a OSB 11gr1 server. However when I install the apps using ant wldeploy task the apps are never made available. No errors in the logs. I find references to the apps in the servers config.xml. I tried creating a new managed server on the same OSB server and install the apps to that instance rather than AdminServer but still the apps are not running after installation.

The same apps works fine if I deploy to a normal weblogic server with no OSB installed. I there any reason why it shouldnt be possible to install more apps in OSB?
  • 1. Re: Cohost JavaEE apps with OSB?
    739930 Newbie
    Currently Being Moderated
    Update: It appears the servlet context of my apps wont start because theres a conflict between my own myfaces shared library and another version of myfaces installed by OSB?



    Caused By: java.io.FileNotFoundException: \Oracle\Middleware\Oracle_OSB1\soa\connectors\FileAdapter.rar!fileAdapter.jar (The system cannot find the file specifi
    ed)
    at java.util.zip.ZipFile.open(Native Method)
    at java.util.zip.ZipFile.<init>(ZipFile.java:114)
    at java.util.jar.JarFile.<init>(JarFile.java:135)
    at java.util.jar.JarFile.<init>(JarFile.java:72)
    at org.apache.myfaces.view.facelets.util.Classpath._getAlternativeJarFile(Classpath.java:272)
    at org.apache.myfaces.view.facelets.util.Classpath._searchResource(Classpath.java:86)
    at org.apache.myfaces.view.facelets.util.Classpath.search(Classpath.java:61)
    at org.apache.myfaces.config.annotation.DefaultAnnotationProvider.getBaseUrls(DefaultAnnotationProvider.java:213)
    at org.apache.myfaces.config.annotation.DefaultAnnotationProvider.getAnnotatedClasses(DefaultAnnotationProvider.java:170)
    at org.apache.myfaces.config.annotation.AnnotationConfigurator.createFacesConfig(AnnotationConfigurator.java:92)
    at org.apache.myfaces.config.DefaultFacesConfigurationProvider.getAnnotationsFacesConfig(DefaultFacesConfigurationProvider.java:148)
    at org.apache.myfaces.config.DefaultFacesConfigurationMerger.getFacesConfigData(DefaultFacesConfigurationMerger.java:91)
    at org.apache.myfaces.config.FacesConfigurator.configure(FacesConfigurator.java:452)
    at org.apache.myfaces.webapp.AbstractFacesInitializer.buildConfiguration(AbstractFacesInitializer.java:303)
    at org.apache.myfaces.webapp.Jsp21FacesInitializer.initContainerIntegration(Jsp21FacesInitializer.java:73)
    at org.apache.myfaces.webapp.AbstractFacesInitializer.initFaces(AbstractFacesInitializer.java:126)
    at org.apache.myfaces.webapp.StartupServletContextListener.contextInitialized(StartupServletContextListener.java:111)
    at weblogic.servlet.internal.EventsManager$FireContextListenerAction.run(EventsManager.java:481)
    at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
    at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:120)
    at weblogic.servlet.internal.EventsManager.notifyContextCreatedEvent(EventsManager.java:181)
    at weblogic.servlet.internal.WebAppServletContext.preloadResources(WebAppServletContext.java:1872)
    at weblogic.servlet.internal.WebAppServletContext.start(WebAppServletContext.java:3153)
    at weblogic.servlet.internal.WebAppModule.startContexts(WebAppModule.java:1508)
    at weblogic.servlet.internal.WebAppModule.start(WebAppModule.java:482)


    I tried adding this to weblogic.xml to load my own library but it appears to have no effect:

         <container-descriptor>
         <prefer-web-inf-classes>true</prefer-web-inf-classes>
         </container-descriptor>

    The myfaces shared library is referenced from my web app using:

    <library-ref>
              <library-name>myfaces-war</library-name>
              <exact-match>true</exact-match>
         </library-ref>
  • 2. Re: Cohost JavaEE apps with OSB?
    786763 Newbie
    Currently Being Moderated
    Although this thread is rather old, the issue still persists.

    Today, I found the following workaround:

    You can deploy a JSF 2.0 application only to managed servers on which the OSB is not deployed on as the issue is caused by the adapters (see below) installed by the OSB. Furthermore, you have to remove these managed servers from the targets of those adapters:

    - AqAdapter
    - DbAdapter
    - FileAdapter
    - FtpAdapter
    - JmsAdapter
    - MqSeriesAdapter
    - OracleAppsAdapter
    - OracleBamAdapter
    - SocketAdapter

    In my case, that's all.

    After that, my application works fine.

    Remark: The issue seems to be caused by this: http://www.goodjavafish.com/2011/05/jsf-oracle-mojarra-211-beware.html

    Let's hope, Oracle will provide a fix for that soon.

    Best regards
    Alexander
  • 3. Re: Cohost JavaEE apps with OSB?
    JuliánIsaza Newbie
    Currently Being Moderated
    Hi, i have the same problem, deployment applicatoi JSF 2.0 in domain soa, i remove the adapter and work fine.

    Other solution for this bug....

    thanks

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points