This discussion is archived
4 Replies Latest reply: Feb 28, 2013 10:30 AM by 9423755 RSS

SQLDeveloper error "Can't load AMD 64-bit .dll on a IA 32-bit platform"

9423755 Explorer
Currently Being Moderated
Hi

I've installed SQL Developer.
It starts, but when I try to connect to the HR database I get the following error message:
An error was encountered performing the requested operation:

C:\oracleee\product\11.2.0\dbhome_1\BIN\ocijdbc11.dll: Can't load AMD 64-bit .dll on a IA 32-bit platform

Vendor code 0
I already have Oracle EE installed, and have installed JDeveloper today. Both are running with no problems.
SQLDeveloper, I initially downloaded without the JDK, but that didn't work, and reading the many replies to other people who had had the same problem (something about mscvr7.dll or some such), as per their exhortations I downloaded the SQLDeveloper that includes the JDK, which happens to be 32 bit (there is no 64 bit SQL Developer with JDK bundled with it). I'm running 64-bit W7.

Can anybody help me here? I don't have much of a clue when it comes to JDKs.

Many thanks,
Jason
  • 1. Re: SQLDeveloper error "Can't load AMD 64-bit .dll on a IA 32-bit platform"
    asahide Expert
    Currently Being Moderated
    Sorry, I've misunderstood..
    Regards,

    Edited by: asahideO on 2013/02/28 15:28
  • 2. Re: SQLDeveloper error "Can't load AMD 64-bit .dll on a IA 32-bit platform"
    9423755 Explorer
    Currently Being Moderated
    >
    Could you try to install JDK 64bit (not bundled)?
    <<http://www.oracle.com/technetwork/java/javase/downloads/index.html>>
    >

    Hi,
    is the problem that I don't have a 64-bit JDK? I thought it might be the other way round.
    I think the following says I have a 64 bit java something, though is that the JRE, rather than the JDK?
    C:\Users\J>echo %JAVA_HOME%
    C:\Program Files (x86)\Java\jre7\bin
    
    C:\Users\J>java -version
    java version "1.7.0_04"
    Java(TM) SE Runtime Environment (build 1.7.0_04-b22)
    Java HotSpot(TM) 64-Bit Server VM (build 23.0-b21, mixed mode)
    
    C:\Users\J>java -d32 -version
    Error: This Java instance does not support a 32-bit JVM.
    Please install the desired version.
    
    C:\Users\J>java -d64 -version
    java version "1.7.0_04"
    Java(TM) SE Runtime Environment (build 1.7.0_04-b22)
    Java HotSpot(TM) 64-Bit Server VM (build 23.0-b21, mixed mode)
    So, am I not running 64-bit? Maybe I need a 32-bit JDK...but then...SQLDeveloper was bundled with a JDK and there was only one option for that - 32bit!

    Thanks,
    Jason
  • 3. Re: SQLDeveloper error "Can't load AMD 64-bit .dll on a IA 32-bit platform"
    Jim Smith Expert
    Currently Being Moderated
    I think the problem is that the 32-bit java jdk is trying load a 64-bit DLL from the windows directory.

    You need to download and install the 64-bit SQLDeveloper and tell it to use the 64-bit JDK.

    It may be that you only have a JRE installed, in which case you will need to download and install a JDK.

    If you have problems making that work, post them here and we can help.


    A work around may be to make sure the 'Use OCI/Thick driver' option in Tools|Preferences|Database|Advance us unchecked. That way SQL Developer shouldn't need to go near the ocijdbc dll
  • 4. Re: SQLDeveloper error "Can't load AMD 64-bit .dll on a IA 32-bit platform"
    9423755 Explorer
    Currently Being Moderated
    >
    You need to download and install the 64-bit SQLDeveloper and tell it to use the 64-bit JDK.
    >

    Hi,
    Thanks, this has worked. I downloaded jdk-7u15-windows-x64.exe and edited sqldeveloper\bin\sqldeveloper.conf:
    SetJavaHome C:\Program Files\Java\jdk1.7.0_15
    (It did give me a warning about the JDK being a higher version than that officially supported but who cares....).
    I also in the meantime found that manually setting the connection information for each connection, adding the port, etc. from tnsnames.ora seemed to obviate the need for the java gubbins to be correctly set-up. But having the path to java set up is of course better in the long run.

    Thanks,
    Jason

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points