4 Replies Latest reply on Feb 28, 2013 6:22 PM by Fabricio_Jorge

    First steps on the Solaris universe

      Hello all,

      I'm starting in a new project where we will install an Oracle database on a Solaris 11. In my hole DBA life, i've only worked with Red Hat, so i am facing some difficulties to understand Solaris and its unique features.

      For example, on my test env (Virtualbox), i installed Solaris 11, with its default (virtual) HardDrive (.vdi), and created (attached) 2 more HDs. After this, i executed the "format" command, which shows me 3 devices (at least i think these are the devices), as follows:
         0   c7t0d0
         1   c7t2d0
         2   c7t3d0
      I suppose disk 0 is the "/", so i didn't do anything to it
      I chose disk 1, formatted via the "format" command and then created a fdisk partition in it, with the fdisk command. I followed these tutorials:


      I think these are the proper steps to prepare a disk for use, or am i wrong?

      Now, i want to mount these devices. On a CentOS, for example i would run "mount -t ext4 /dev/sdb1 /app", correct? But how do i run this equivalent command on a Solaris 11 environment?

      Thanks in advance.