This discussion is archived
7 Replies Latest reply: Mar 3, 2013 12:44 AM by HartmutStreppel RSS

[SC 3.3] Zone-Question

924908 Newbie
Currently Being Moderated
Hello @all,

I've created a failoverzone:

zonecfg -z bstzone
create -b
set zonepath=/zones/bstzone
set autoboot=false
add net
set address=10.253.156.54
set physical=vnet0
end
commit
exit

Within my cluster I've create a logicalhostname ip ressource:

clreslogicalhostname create -g bst-rg \
-p Resource_project_name= \
-p Failover_mode=SOFT \
-p R_description=Failover\ network\ resource\ for\ bst831 \
-N ref@1,ref@2 \
-h bst831 IP_bst831

and the zone ressource:

cd /opt/SUNWsczone/sczbt/util

cp -p sczbt_config sczbt_config_bstzone-bt-rs

vi sczbt_config_bstzone-bt-rs
RS=bstzone-bt-rs
RG=bst-rg
PARAMETERDIR=/etc/zoneagentparams
SC_NETWORK=true
SC_LH=IP_bst831
FAILOVER=true
HAS_RS=bstpool-dg
Zonename="bstzone"
Zonebrand="native"
Zonebootopt=""
Milestone="svc:/milestone/multi-user-server"
LXrunlevel="3"
SLrunlevel="3"
Mounts=""


./sczbt_register -f ./sczbt_config_bstzone-bt-rs


Now my problem:

Whenever I disable the logicalhostname ressource IP_bst831 ( which is "mounted" into the zone )
my zone is going offline!

What I want is if the zone is started, the logicalhostname IP_bst831
should be mounted into the zone and when I disable the logicalhostname IP_bst831
the zone should stay online!

The cluster group itself is created with Implicit_network_dependencies=FALSE.

Please keep in mind: bst831 != 10.253.156.54


Any help would be appreciated!

Regards,
Heinz
  • 1. Re: [SC 3.3] Zone-Question
    HartmutStreppel Explorer
    Currently Being Moderated
    Hi,
    but you have set:
    SC_NETWORK=true
    SC_LH=IP_bst831
    in your sczbt config file. Why this? I assume, that when you remove these two it'll work as expected.
    Regards
    Hartmut
  • 2. Re: [SC 3.3] Zone-Question
    924908 Newbie
    Currently Being Moderated
    Hi,

    ok, I thought that the zone ressource which is created upon the parameter file,
    has to know which logicalhostname has to be imported.

    Ok, I'll give it a try.

    Regards,
    Heinz
  • 3. Re: [SC 3.3] Zone-Question
    924908 Newbie
    Currently Being Moderated
    Seems not to work:

    RS=bstzone-bt-rs
    RG=bst-rg
    PARAMETERDIR=/etc/zoneagentparams
    SC_NETWORK=
    SC_LH=
    FAILOVER=true
    HAS_RS=bstpool-dg

    #
    # The following variable will be placed in the parameter file
    "sczbt_config_bstzone-bt-rs" 159 lines, 5633 characters
    [root]/opt/SUNWsczone/sczbt/util: ./sczbt_register -f ./sczbt_config_bstzone-bt-rs
    sourcing ./sczbt_config_bstzone-bt-rs
    There is no value configured for variable SC_NETWORK within the sczbt_config file!

    Regards,
    Heinz
  • 4. Re: [SC 3.3] Zone-Question
    HartmutStreppel Explorer
    Currently Being Moderated
    I would assume that you have to set SC_NETWORK=false. The documentation inside that configuration file should tell you.
  • 5. Re: [SC 3.3] Zone-Question
    924908 Newbie
    Currently Being Moderated
    Hartmut,

    now I'm able to register the zone:

    RS=bstzone-bt-rs
    RG=bst-rg
    PARAMETERDIR=/etc/zoneagentparams
    SC_NETWORK=false
    SC_LH=
    FAILOVER=true
    HAS_RS=bstpool-dg


    [root]/opt/SUNWsczone/sczbt/util: ./sczbt_register -f ./sczbt_config_bstzone-bt-rs
    sourcing ./sczbt_config_bstzone-bt-rs
    Registration of resource bstzone-bt-rs succeeded.
    Validation of resource bstzone-bt-rs succeeded.


    But the logicalhostname IP_bst831 is not imported into the zone!
    I think because parameter SC_LH= is empty and has to be set to the LH resource IP_bst831.
    Maybe I have to play with the Recource_dependencies parameter.

    I'll try it with different settings and if I'm successful I'll post the answer.

    Thanks for your help!

    Regards,
    Heinz
  • 6. Re: [SC 3.3] Zone-Question
    924908 Newbie
    Currently Being Moderated
    Hartmut,

    now I'm able to register the zone:

    RS=bstzone-bt-rs
    RG=bst-rg
    PARAMETERDIR=/etc/zoneagentparams
    SC_NETWORK=false
    SC_LH=
    FAILOVER=true
    HAS_RS=bstpool-dg


    [root]/opt/SUNWsczone/sczbt/util: ./sczbt_register -f ./sczbt_config_bstzone-bt-rs
    sourcing ./sczbt_config_bstzone-bt-rs
    Registration of resource bstzone-bt-rs succeeded.
    Validation of resource bstzone-bt-rs succeeded.


    But the logicalhostname IP_bst831 is not imported into the zone!
    I think because parameter SC_LH= is empty and has to be set to the LH resource IP_bst831.
    Maybe I have to play with the Recource_dependencies parameter.

    I'll try it with different settings and if I'm successful I'll post the answer.

    Thanks for your help!

    Regards,
    Heinz
  • 7. Re: [SC 3.3] Zone-Question
    HartmutStreppel Explorer
    Currently Being Moderated
    Now, we seem to get stuck. It seems to me that the sczbt agent only handles IP addresses that are part of the config file. Let me check with the author.

    As a workaround, couldn't you create another RG with just this one IP address and tie it to the zone RG with some form of positive affinity? Just a thought - I have no time to test this next week.
    Regards
    HArtmut

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points