This discussion is archived
6 Replies Latest reply: Mar 4, 2013 6:06 AM by 949261 RSS

OEM Jobs not running in 12C

949261 Newbie
Currently Being Moderated
My OEM jobs and reports are not running, either in real time or as scheduled
When a job I submitted to run immediately, it shows a status of “Scheduled” with the current time but does not run. Also a scheduled job shows the correct scheduled time but does not run.

I have now noticed that the jobs referred to above all run at 01.01 hours , so it appears that all scheduled and one time immediately jobs all run at 01.01

When I go to Setup -> Manage Cloud Control -> Health Overview page, the Job System Status is “status Pending” with a yellow triangle
  • 1. Re: OEM Jobs not running in 12C
    MarkM Explorer
    Currently Being Moderated
    Hello,

    Could you log a Service Request with Oracle Support for this issue and post the SR # back to this thread?

    Thanks, Mark.
  • 2. Re: OEM Jobs not running in 12C
    RaySmith Oracle ACE
    Currently Being Moderated
    1. Connect to the repository database as the SYSMAN user and execute the following

    alter system set job_queue_processes=10;

    exec emd_maintenance.remove_em_dbms_jobs;

    exec emd_maintenance.submit_em_dbms_jobs;

    commit;

    2. Log into the OEM console

    Click on Repository Database Target in Cloud Control

    Click on Administration/Oracle Scheduler/Home

    Then click on "Oracle Scheduler; it will return, "Scheduler Jobs"

    Check that the scheduled jobs are running at their correct schedules. eg. check 'EM_JOBS_MONITOR' which should run every 5 minutes. Check that the "scheduled date" is five minutes after the last run date", and check that it's in status "SCHEDULED".

    These jobs have different scheduled running intervals, so certain jobs only run once a day, and one only runs once a week. It's possible to view the scheduled interval by clicking on "view job definition".
  • 3. Re: OEM Jobs not running in 12C
    949261 Newbie
    Currently Being Moderated
    Thanks Ray,

    I have tried the steps suggested, however whenI log into Repository Database Target in Cloud Control
    Click on Administration/Oracle Scheduler/Home, I can't find EM_JOBS_MONITOR in the list of scheduler Tasks, I cam see EM_JOBS_STEP_SCHED. How can I add EM_JOBS_MONITOR

    Thanks
  • 4. Re: OEM Jobs not running in 12C
    522945 Newbie
    Currently Being Moderated
    Have you applied PS1 for 12c? If so, EM_JOB_MONITOR should not be available - you need not bother about its absence.
  • 5. Re: OEM Jobs not running in 12C
    522945 Newbie
    Currently Being Moderated
    Could you please check whether the timezone setting of the RDBMS is correct and systimestamp/sysdate return the correct values?

    On mouse-over of the yellow triangle, do you see any message?
  • 6. Re: OEM Jobs not running in 12C
    949261 Newbie
    Currently Being Moderated
    Thanks for all your responses, it was a space issue on mgmt_tablespace, which meant no jobs could run

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points