1 Reply Latest reply on Mar 4, 2013 2:32 PM by Michael Ferrante-Oracle

    Worked in 9i not 11g


      I am in the process of migrating from Forms 9i to 11g.

      There is on form that works like this:

      1. User has a device connect to the PC where they enter a value
      2. User opens form, navigates to the desired field and presses a button on the device which inserts the value into the field.
      3. The WHEN-VALIDATE-ITEM is fired (without user intervention) that contains a COMMIT_FORM which commits the form and then a new record is opened.


      Item 3 from above does not work without user intervention.

      Any ideas?


      Bill Chadbourne
        • 1. Re: Worked in 9i not 11g
          Michael Ferrante-Oracle
          In order to fully understand what you are talking about, we need to know exactly which product versions you are using. Forms 9i and Forms 11g are product names and potentially represent many possible version numbers.

          Also, how does the device integrate with the Forms application? Is it connected to the client machine? If so, your 11.1.x form will need to have a java bean in order to communicate with it. Do you have one?

          One last thing, WHEN-VALIDATE-ITEM will only fire when navigation leaves the field. This means that you need to either programatically leave the field or the user must click away from the field.