2 Replies Latest reply on Mar 6, 2013 5:22 AM by 845153

    Getting Table or View doesn't exit in OBIEE Apps 10g

      Hi All,

      I have view derived from 2 facts f1&f2 say WIP_v and the view is joined with f1 ( with 4 joins b/n them - complex join) in Physical Layer. In BMM layer WIP_v and f1 is having inner join. Now the issue is user want to see all the data from WIP_v ( though it is null he want to see ). Hence modifed join from Inner to RightOuter in BMM layer between WIP_V and f1. After giving right outer join getting " Table or View doesn't exit error. Checked the backend query, it is bringing in Login_party and few tables which I was never joined with f1.

      Option 1 : Tried creating new LTS for F1 and brought WIP_V under General tab and tried giving Outerjoin between WIP_V and F1, it is not throwing any error but all values from WIP_v is not getting displayed.

      Ex: Ordernum Order amount WIP_v_column

      123 3456 Y or N

      As of now when I create above report gives no results page if I user option1.

      But if query only 2 columns without WIP_V column and I am getting results Ex: Ordernum Order amount

      123 3456
      Help me out..... Thanks in anticipation

      Edited by: Aari on Mar 2, 2013 2:48 AM
        • 1. Re: Getting Table or View doesn't exit in OBIEE Apps 10g

          Make Sure you dont have Any Consistency Errors/warnings in the RPD first.

          Then debug step by step like query (in Answers)only only from each table and see whats happening thru physical query from backend.

          Make sure you have correct joins in BMM.

          Table or View doesnot exist occur when there is no table in the database, MAke sure your connection pool DSN is pointing correct!!

          If possible try to paste the error.

          Update me

          • 2. Re: Getting Table or View doesn't exit in OBIEE Apps 10g
            Hi DNK,

            Repository is being used by many people. Report is working fine if I give Inner join between WIP_V fiew and fact1. Only if give Right outer join between them, then it is throwing table view doesnot exit.

            RPD is pointing to correct DB.

            I belive OOB tables are causing problem here.

            Let me know if you need more info