2 Replies Latest reply: May 14, 2013 1:01 PM by Gary Graham-Oracle RSS

    Unable to open a database connection on SQL Developer

    995072
      Windows XP
      SQL Developer 3.1.07
      Java Platform 1.6.0_11

      Im not sure why SQL developer is not allowing me to open a database connection thru existing Connection.xml file. When I open SQL Developer, the UI opens but it does not prompt me for a new connection. All I see is the menu bar, the shortcut icons then a blank pane. When I click File>Open, I dont get a dialog box. When I try do File>exit, an Externally Modified Files prompt is displayed saying "..root\Application Data\SQL Developer\system3.1.07.42\o.ide.11.1.1.4.37.59.48\Debugging.layout has been externally modified. Reload?". I choose no and a Close Application prompt is displayed with "Oracle SQL Developer Data Modeler is waiting for tasks that should finish, such as writing files. If you select Exit now, possibly lose data might be lost or files may be corrupted." When I click Exit now... I get that Externally Modified Files prompt again. And it just loops. So I go to task manager to end the application.

      I just recently got a new laptop and installed SQL Developer thru below steps:
      1. Copied existing sqldeveloper-3.1.07.42.zip.
      2. Extracted the sqldeveloper-3.1.07.42.zip file.
      3. Run sqldeveloper.exe.

      I have Java SE Development Kit 6 Update 43 installed. Am I missing a few more steps in installing this tool?

      I cant seem to do any querying

      Edited by: victor8 on 5/03/2013 23:36
        • 1. Re: Unable to open a database connection on SQL Developer
          1008848
          You created a script to limit your connections. I don't understand. Clever planning.

          Edited by: 1005845 on May 14, 2013 7:16 AM
          • 2. Re: Unable to open a database connection on SQL Developer
            Gary Graham-Oracle
            Hi,

            I missed what was said prior to the edits on the earlier posts but, from the comments that remain, it appears the preference settings got corrupted somehow. To begin again with a completely clean install, first rename your "system3.1.07.42" directory to something else (maybe badsystem3.1.07.42), then follow a slightly modified version of your 3 step process:

            1. Copy existing sqldeveloper-3.1.07.42.zip.
            2. Extract the sqldeveloper-3.1.07.42.zip file into an empty directory*
            3. Run sqldeveloper.exe but do not accept the offer to migrate settings*
            4. You can try retrieving your existing connection definitions by importing from the old connections.xml file.

            Of course, downloading and installing the latest production SQL Developer (sqldeveloper-3.2.20.09.87.zip) would be even better.

            Regards,
            Gary