2 Replies Latest reply: Mar 6, 2013 4:51 AM by rameshecm RSS

    Unable to login into OBIEE10g Application

    rameshecm
      Hi,

      We have an OBIEE10g production application which is running on UNIX machine. All of sudden production reports become very slow and running on and on. So I thought of restarting the services. I have brought down all the services (sa,saw and oc4j) and brought back up all the services. All the services are running perfectly . But when I am logging in to the application I am getting the following error

      Error:
      Unable to Log In
      Error connecting to the Oracle BI Server: Could not connect to the Oracle BI Server because it is not running or is inaccessible. Please contact your system administrator.
      Error Details
      Error Codes: WH4KCFW6:OPR4ONWY:U9IM8TAC

      Odbc driver returned an error (SQLDriverConnectW).
      State: HY000. Code: 10058. [NQODBC] [SQL_STATE: HY000] [nQSError: 10058] A general error has occurred. [nQSError: 12008] Unable to connect to port 9703 on machine LOCALHOST. [nQSError: 12010] Communication error connecting to remote end point: address = LOCALHOST; port = 9703. [nQSError: 12002] Socket communication error at call=: (Number=-1) Unknown error 4294967295 (HY000)

      From last one month, we haven't deployed any code or any changes to the production repository and application is running fine. Not sure all of sudden we got into this login issue.

      As part of my analysis I have done the following steps:

      1)When I Placed the same rpd and webcat in windows box ,I am able to login and able to see the reports in few seconds.
      2) Removed all the INIT blocks and few Subject Areas from the repository and placed the same rpd on Production box again(UNIX) . Then I could able to login to production application with the Administrator user. Then I thought that it could be a space issue on prod machine. But I just picked up few columns from dimention with limited data (filter applied for single customer Number),the ad-hoc report is running on and on. It is keep on refreshing. I have got the query from manage sessions and run it in database. I am getting the results in database.

      Not getting any clue.This is very urgent . Can you pls. share your thoughts in this regard. Quick response is highly appreciated.

      Thanks,
      Ramesh
        • 1. Re: Unable to login into OBIEE10g Application
          Srini VEERAVALLI
          1. Update all your OBIEE configuration files NQSConfig.ini, odbc.ini and instanceconfig.xml to use a fixed IP address for the OBIEE server instead to referring to local host.
          2. Save the changes and re-start the service.

          If helps mark

          Edited by: Srini VEERAVALLI on Feb 14, 2013 9:13 PM
          • 2. Re: Unable to login into OBIEE10g Application
            rameshecm
            Hi Srini,

            Sorry for the delay on my reply.

            Actaul issue is due to space issue on the production (UNIX) machine where OBIEE server is actuall running. Due to the space unavilability on the production machine, Oracel client is not able to make the proper handshake with Oracle server (Oracle server existed on different machine).

            So I have cleared the space (Archive files) on the production machine (UNIX box) and restarted the machine and then started all the required services on the production machine. Then onwards, we were able to login into OBIEE Application.

            Thanks,
            Ramesh