This discussion is archived
3 Replies Latest reply: Mar 6, 2013 11:30 PM by 994648 RSS

mod_plsql DAD Configuration File problem.

994648 Newbie
Currently Being Moderated
hi there im new here.
i have a question.

i used to oracle 9i version that has oracle http server included. i has a plsql application by the way. its running on oracle http server. i wanted to upgrade it oracle 11g.
so i installed oracle11g and imported db to 11g. its ok so far. then i noticed that 11g has no http server. i downloaded and installed oracle middleware fusion 11g web tier.
but i checked only Oracle Http Server choise when i was installing.

my oracle home is 'C:\Oracle\product\11.2.0\ora_home'
my middleware instance home is 'C:\Middleware\Oracle_WT1\instances\instance1\config\OHS\ohs1'

I changed the dads.conf file where is 'C:\Middleware\Oracle_WT1\instances\instance1\config\OHS\ohs1\mod_plsql' as below.

<Location /pls/mre>
SetHandler pls_handler
Order deny,allow
Allow from all
AllowOverride None
PlsqlDatabaseUsername user
PlsqlDatabasePassword pass
PlsqlDefaultPage plogin.login?wb_srv=M1&plang=0
PlsqlDocumentTablename document
PlsqlDocumentPath docs
PlsqlAuthenticationMode Basic

but i got error like that.

Internal Server Error
+The server encountered an unknown error, possibly due to misconfiguration. Contact the server administrator: [no address given]+
More information about this error may be available in the server error log.

i have tried many things for PlsqlDatabaseConnectString. but none of them worked. Also some tryings returned a message like that : bad request.
i think problem is PlsqlDatabaseConnectString thing.
i researched this problem so many times. but i never made it work.

when i typed PlsqlDatabaseConnectString w00
then i got error like that

Service Temporarily Unavailable
The server is currently unable to handle the request due to a temporary overloading or maintenance of the server.
when i typed PlsqlDatabaseConnectString localhost:1521:w00
then i got error like that
Bad Request
The request could not be understood by server due to malformed syntax.

Could u please help me with this.

Best Regards.


  • Correct Answers - 10 points
  • Helpful Answers - 5 points