This discussion is archived
10 Replies Latest reply: Mar 6, 2013 1:24 PM by user9078932 RSS

ODI Console deployment failed

user9078932 Newbie
Currently Being Moderated
Hi guys,

I've configured ODI console as Managed Server and can start it successfully from Weblogic Admin console. However in the "Deployments" tab its status is failed. That's how I receive the "Error 404--Not Found" when I enter the ODI console URL.

I'm young to Weblogic. How to diagnose what cause the deployment failed?

Thanks,
Jeffrey
  • 1. Re: ODI Console deployment failed
    Ayush Ganeriwal Journeyer
    Currently Being Moderated
    You should look into the managed server log file and look for the exception causing failure in odi console startup.

    You can also refer to the documentation on configuring WLS domain to make sure you haven't miss anything.
    http://docs.oracle.com/cd/E23943_01/core.1111/e16453/configure.htm#CHDGHIEF
  • 2. Re: ODI Console deployment failed
    user9078932 Newbie
    Currently Being Moderated
    Hi Ayush,

    Where can I find the managed server log file?

    Thanks,
    Jeffrey
  • 3. Re: ODI Console deployment failed
    992216 Newbie
    Currently Being Moderated
    Jeffrey,

    U can look the Managed server log file in the below location.

    <Webserver location>user_projects\domains\ODI-DOMAIN\servers\odi_server1\logs

    Sandeep
  • 4. Re: ODI Console deployment failed
    tina.wang Journeyer
    Currently Being Moderated
    generally, you can see enough exceptions in the console where you run startManagedServer odi_server1
    have you create credential using wlst
    in the same folder to run config.sh, run wlst.sh, I suggest you to run
    createCred(map="oracle.odi.credmap", key="SUPERVISOR", user="SUPERVISOR", password="welcome1", desc="ODI Login")
    createCred(map="oracle.odi.credmap", key="base_domain", user="weblogic", password="welcome1", desc="WLS credentials")
    createCred(map="oracle.apps.security", key="SUPERVISOR", user="SUPERVISOR", password="welcome1", desc="ODI Login")
    createCred(map="oracle.apps.security", key="weblogic", user="SUPERVISOR", password="welcome1", desc="ODI Login")
  • 5. Re: ODI Console deployment failed
    user9078932 Newbie
    Currently Being Moderated
    Hi Tina and Sandeep,

    I found the following error in the log file:

    Failed to invoke startup class "JRF Startup Class", java.lang.ClassNotFoundException: oracle.jrf.wls.JRFStartup java.lang.ClassNotFoundException: oracle.jrf.wls.JRFStartup at java.net.URLClassLoader$1.run(URLClassLoader.java:202) at java.net.URLClassLoader.findClass(URLClassLoader.java:190) at java.lang.ClassLoader.loadClass(ClassLoader.java:305) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308) at java.lang.ClassLoader.loadClass(ClassLoader.java:246) at java.lang.Class.forName0(Native Method) at java.lang.Class.forName(Class.java:247) at weblogic.management.deploy.classdeployment.ClassDeploymentManager.invokeClass(ClassDeploymentManager.java:262) at weblogic.management.deploy.classdeployment.ClassDeploymentManager.access$000(ClassDeploymentManager.java:54) at weblogic.management.deploy.classdeployment.ClassDeploymentManager$1.run(ClassDeploymentManager.java:214) at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321) at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:120) at weblogic.management.deploy.classdeployment.ClassDeploymentManager.invokeClassDeployment(ClassDeploymentManager.java:246) at weblogic.management.deploy.classdeployment.ClassDeploymentManager.runStartupsBeforeAppDeployments(ClassDeploymentManager.java:149) at weblogic.management.deploy.classdeployment.ClassDeploymentService.start(ClassDeploymentService.java:21) at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64) at weblogic.work.ExecuteThread.execute(ExecuteThread.java:209) at weblogic.work.ExecuteThread.run(ExecuteThread.java:178)

    I have edited the commEnv.cmd file by adding $MW_HOME\modules\oracle.jrf_11.1.1\jrf.jar to WEBLOGIC_CLASSPATH but still got the same error.

    Question: Is WEBLOGIC_CLASSPATH in commEnv.cmd file the right place to setup?

    Thanks,
    Jeffrey
  • 6. Re: ODI Console deployment failed
    tina.wang Journeyer
    Currently Being Moderated
    Neally all Oracle web application are developped using ADF Faces since 11g. Odi Console is same.
    In general, you don't need to modify any classpath for ADF Faces library, it include several jars, if oracle let customers to do that, it's so inconvenient.

    You need to get correct weblogic installer in otn, every odi release has its corresponding weblogic version, if you choose wrong version, it might cause issue.

    install weblogic, install odi in the same mw_home of weblogic using j2ee mode(btw, you can also install dev or standalone mode in the same mw_home, it does not matter)
    then in $mw_home\Oracle_ODI1\common\bin, run config.bat (.sh), choose component(s) template, if you choose odiconsole, jrf library template is chosen automatically for you.
    then start admin sever, run wlst to create cred, then start managed server

    we have tested in the complete 11g releases, no issues.
  • 7. Re: ODI Console deployment failed
    992216 Newbie
    Currently Being Moderated
    Jeffrey,

    Follow the link instructions and go ahead ,
    http://odiexperts.com/11g-odiconsole-part-511/

    As Tina said all the Libraries will pick automatically in the process of creations.
    Change the modified files back to Old/Orginal file.

    Sandeep
  • 8. Re: ODI Console deployment failed
    user9078932 Newbie
    Currently Being Moderated
    Hi Tina, Sandeep,

    I doubt it has something to do with my environment because I've followed exactly the same instructions in that link. Do you think the following components in my environment are compatible?
    - Windows 7 64-bit
    - Weblogic 10.1.35
    - ODI 11.1.1

    Since my Windows is 64-bit, I have to use the installer in the Disk1\install\win64 folder, and I also have to use JDK1.7.0 I downloaded rather than JDK160_24 that comes with weblogic. If I use JDK160_24 to do the installation, the setup.exe just quit after a while.

    Thanks,
    Jeffrey
  • 9. Re: ODI Console deployment failed
    tina.wang Journeyer
    Currently Being Moderated
    odi is 11.1.1.3 or .5, .6 ?
    have you used wls1035_generic.jar?
  • 10. Re: ODI Console deployment failed
    user9078932 Newbie
    Currently Being Moderated
    Tina,

    The ODI version is 11.1.1.6.

    As for Weblogic, wls1035_win32.exe is the file name. I haven't got the time to test the one you mentioned. Could this be an issue?

    Thanks,
    Jeffrey

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points