0 Replies Latest reply: Mar 6, 2013 6:44 PM by EdSpn RSS

    Config collected but not shown - error instead

    EdSpn
      Hi all,

      I am stuck with a very simple plugin that does all, except showing the last collected configuration data.

      The data is collected, the ECM management table is populated. However, when I click the name of the configuration metric in the UI to show the last collected data, it comes up with an error popup:
      ORA-01747: invalid user.table.column, table.column, or column specification
      oracle.sysman.emSDK.app.exception.EMSystemException
      I have no performance metrics in this plugin and only 1 configuration metric; it's very simple... I have tried to check all there is and can see no issues in any of the 3 main xml files (target type definition, default collection and ecm/snapshot xml file).

      In $OMS_LOG/emoms.log I do see a message but it doesn't give enough for me to find the root cause of this issue:
              :
              at oracle.sysman.emSDK.core.util.jdbc.PreparedStatementWrapper.executeQuery(PreparedStatementWrapper.java:328)
              at oracle.sysman.core.ecm.uimodel.browser.applicationModule.BrowserAMImpl.populatePropertiesTable(BrowserAMImpl.java:610)
              ... 81 more
      2013-03-06 18:22:29,770 [[ACTIVE] ExecuteThread: '19' for queue: 'weblogic.kernel.Default (self-tuning)'] ERROR applicationModule.BrowserAMImpl logp.251 - SQ
      LException occured while populating table
      java.sql.SQLSyntaxErrorException: ORA-01747: invalid user.table.column, table.column, or column specification
      
              at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:462)
              at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:405)
              :
      Any input much appreciated!

      Thanks,
      Ed