This discussion is archived
1 2 Previous Next 19 Replies Latest reply: Mar 8, 2013 9:24 PM by Aman.... Go to original post RSS
  • 15. Re: dbca and diskgroup
    User477708-OC Journeyer
    Currently Being Moderated
    by any chance, is this 1 of several attempts youve made to do this? Ive installed ASM many times on windows and I think I recall seeing this issue once after I had a couple of failed install attempts. ie, DBCA wasnt seeing the disks no matter what I did even though asmtool does see it. AFAIR, I wiped the asm stamps, then the partitions off the disks with diskpart, bounce the machine, re-create the logical partitions, stamp with ASM, then run dbca, then I was able to see it. I may even have had to get storage to re-present the disks themselves and while this may not have been the deciding factor I just remember I had to completely start from scratch to get DBCA to see them when it should have worked anyway.

    also, make sure you run DBCA as administrator...
  • 16. Re: dbca and diskgroup
    sonidba Newbie
    Currently Being Moderated
    After struggling with this problem for so many days, today I get to know the fault. I tried installation on lots of version of Windows . But dbca was failing everywhere. dbca was unable to display the diskgroup. Today suddenly, one idea struck on my mind. Change the database software. Just change the database software. I asked for the database software from one of my colleague. The size of database sotware was really different. Mine was 2.15 GB. And the one that I received from my colleague was of size 2.12 GB. I start fresh installation once again hoping for some good result. This time, dbca works.
    Unbelievable. How can it be possible that some of the features were working properly but some were not. The version for both the software was also the same. database was able to create properly on filesystem. But it was unable to create on the top of ASM.

    I was too shocked with this kind of unexpected behavior on the part of dbca. I was performing everything from administrator, even this of behavior! shocking! and Unexpected too!

    I had already tried all the solutions after google-ed. Administrator was the member of ora_dba and other solutions also. Still the error. Today I really got a relief.
  • 17. Re: dbca and diskgroup
    Aman.... Oracle ACE
    Currently Being Moderated
    I am not sure that anything relevant can be said about the "workaround" except that you may have a missing file or something in the previous download than the later one. But if it worked, that's good!

    Try to use OEL,it's much better than using Windows.

    Aman....
  • 18. Re: dbca and diskgroup
    sonidba Newbie
    Currently Being Moderated
    Thanks for reply Aman.

    I am DBA consultant providing training to clients according to their requirements. If client wants their training to be conducted on Windows, then we need to go with the client.
    I too prefer Linux environment. Could you please specify reasons why should one go for Linux environment/OEL.
  • 19. Re: dbca and diskgroup
    Aman.... Oracle ACE
    Currently Being Moderated
    Yes, I know , some times, requirements even when they have a scope of improvement, have to be fulfilled.

    I won't say that there is anything wrong in Windows but I haven't used it now to install Oracle from a long time. On my Windows machines, I just put Virtual Box and install Oracle over OEL. Given that one knows how to use Windows properly , it's not a bad o/s too.

    Aman....
1 2 Previous Next

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points