7 Replies Latest reply on Mar 8, 2013 8:12 PM by Bjoern Rost

    Migrating local repos to a new storage storage system

      I've currently got an OVM server that has all it's storage on "Unmabaged FibreChannel Storage Array". All of these disks are assigned via SVC. We have recently upgraded our storage and are in the process of migrating out of our "end of life" storage and into our new. Both are on the same SVC IO group. For many of our other physical servers, we have used LVM to migrate live filesystems to the new storage, then removing the old. I have not been able to figure out a way to effectively do this with my OVM environment. Has anyone out there moved an OVM installation that wasn't NFS?

      I actually have to do this with 2 OVS but they are in different datacenters and do not utalize HA due to the storage setup. If it is possible for me to migrate some of my VMs to that other server (even manually) to aid in this procedure, I'd be willing to entertain that as well. I have an OVM test environment with the same basic setup as my production servers (with a lot less resources) that I can use to test solutions.

      This is a production OVS so I'l like to have as little down time as possible but at this point I'll just be happy if I can move it. Any assistance would be appreciated.


        • 1. Re: Migrating local repos to a new storage storage system
          Create a new repo on your new storage. Clone or move your existing VM guests to the new repo. Startup your new clones. Supposedly you can create a hot clone if the guest on FC or ISCSI. Never tried it. All my repos at the moment are on NFS.

          If you storage allows replication. You could probably replicate your repos and retain the proper UUIDs for your existing repos. Depends on the product you use. You could then just disconnect your old storage. If you're going to move across repo types. Then move/clone is the only method I've used. I always shutdown the guest.
          1 person found this helpful
          • 2. Re: Migrating local repos to a new storage storage system
            Your answer is exactly correct and has allowed me to move my VMs. One issue remains however, my pool filesystem is also on FC storage attached to the server. I can create a new server but when I try and move it into a new pool (still attached to the OVS but assigned from my new storage) I am unable to move the server. I get receive the following...

            Job Construction Phase
            com.oracle.ovm.mgr.api.exception.RuleException: OVMRU_000036E Cannot remove server: challengertest.systems.wvu.edu, from pool: challengertestpool. There are still OCFS2 file systems: [fs_original, fs_clone], in the pool

            ...and so on...

            The fs_original is the repo that is on my old storage, the fs_clone is the repo on the new storage. These are both unpresented to the server. I also have already moved my VMs into the "Unassigned Virtual Machines" folder. There are no files/imgs/etc on the fs_original, everything has been copied to the fs_clone.

            Any clue how to move the server into the newly created pool? Or even to delete it and rediscover it? When I try and delete it I get the same message as I do when trying to move it (the one above).

            • 3. Re: Migrating local repos to a new storage storage system
              I believe there is a bug on this. What version you running?

              Also, try moving your server to unassigned servers before you try to connect it to your new server pool.

              1. Move your server to unassigned servers.
              2. Create a new storage path for your server pool.
              2. Create a new pool with a different filesystem path. During creation, add your servers to the new pool.

              I personally use NFS for Server pools. Its simply and your pools are just based on shares. There is very little space needed and very little IO associated with a server pool.
              1 person found this helpful
              • 4. Re: Migrating local repos to a new storage storage system
                Oracle VM Manager
                Build: 20120430_305

                Oracle VM Server
                Version: 3.0.3
                Not sure where to check the build.

                I understand that the Manager and Server "should" be the same version. I wanted to test as much of this on my upgraded manager before upgrading the hypervisor.

                You help is greatly appreciated!



                Oh, and to answer the 2nd part of the question... I have tried it both ways, trying to move the server to Unassigned before and after adding the new pool FS. Both react the same way. Those 2 repo fs are still attached to the server but not presented. If that makes any sense.

                Edited by: phatatma on Mar 8, 2013 8:07 AM
                • 5. Re: Migrating local repos to a new storage storage system
                  I would definitely upgrade your VM server to match the VM manager version. There is quite a bit of difference between 3 and 3.1.1. I've had good success with 3.1.1-485.

                  You could open a SR with Oracle but I wouldn't doubt they will tell you to at least upgrade the VM server to match the edition of the VM Manager.
                  • 6. Re: Migrating local repos to a new storage storage system
                    I am in the process of upgrading both the Manager and Server to 3.2.1, that appears to be the latest they have available. Yes, Oracle support will tell you that different versions are not supported. I'll update this thread once I see if upgrading the machines helps out.
                    • 7. Re: Migrating local repos to a new storage storage system
                      Bjoern Rost
                      can you remove the old repository and/or make sure that the server you are trying to move is not a management server for it? Also, the most recent version is 3.2.2 which was released just a few days ago. I updated today without any issues.