4 Replies Latest reply: Mar 13, 2013 12:00 PM by 990699 RSS

    R12 prerequisites - i386 packages from the eDelivery files downloaded

    990699
      Hi,

      I have installed Oracle Linux 5.8 (from the iso image Oracle Linux Release 5 update 8 for x86 - 32bit from Part Number v31119-01) so I can install Oracle R12.

      Oracle Support ID 761564.1 states that the following i386 packages must be installed from the Oracle Linux 5 or RHEL 5 distribution media:

      •compat-glibc-2.3.4-2.26
      •compat-glibc-headers-2.3.4-2.26
      •gcc-4.1.2-14.el5
      •gcc-c++-4.1.2-14.el5
      •glibc-2.5-123
      •glibc-common-2.5-123
      ....etc....

      I would appreciate if you could help me how I can install the above RPMs from the distribution media.

      Thanks in advance.
        • 1. Re: R12 prerequisites - i386 packages from the eDelivery files downloaded
          Dude!
          The following should take care of the software per-requisites, kernel parameters and oracle account:
          yum install oracle-validated
          • 2. Re: R12 prerequisites - i386 packages from the eDelivery files downloaded
            990699
            Hi,

            I get the below No package oracle-validated available.

            [root@Test123 ~]# yum install oracle-validated
            Loaded plugins: rhnplugin, security
            This system is not registered with ULN.
            ULN support will be disabled.
            Setting up Install Process
            No package oracle-validated available.
            Nothing to do


            Also how do I install all the RPMs without YUM. I am looking into install the RPMs from the eDelivery downloaded file.

            Thanks.
            • 3. Re: R12 prerequisites - i386 packages from the eDelivery files downloaded
              Dude!
              Also how do I install all the RPMs without YUM
              Why would you want to do this? YUM is a front-end for RPM and standard since Enterprise Linux 5. YUM sorts out package dependencies and prevents you from screwing up your system installation. RPM does not.

              You can configure the yum configuration to use the software repository from your installation DVD if necessary:

              Copy and paste the following to the command line as user root:
              cat > /etc/yum.repos.d/dvd.repo <<EOF
              [Install_DVD_base]
              name=Install DVD
              baseurl=file:///mnt/cdrom/Server
              gpgcheck=1
              enabled=1
              skip_if_unavailable=True
              EOF
              #
              
              mkdir -p /mnt/cdrom
              Then insert the OS installation DVD and mount it. Or mount the downloaded ISO installation disk image file:
              umount /dev/cdrom
              mount /dev/cdrom /mnt/cdrom
              or
              umount /dev/cdrom
              mount -o loop file.iso /mnt/cdrom
              Import the GPG key:
              rpm --import /mnt/cdrom/RPM-GPG-KEY-oracle
              Install the software packages you need using yum:
              yum install gcc
              Or trigger the installation of all prerequisites at once using the following:
              yum install oracle-validated
              If you would rather access the Internet and get the last up to date packages instead of using local installation media, follow the instructions at http://public-yum.oracle.com
              • 4. Re: R12 prerequisites - i386 packages from the eDelivery files downloaded
                990699
                Thanks. I have used YUM and it worked perfect.