5 Replies Latest reply on Mar 13, 2013 8:44 PM by 668461

    Dependency conflicts when installing WebLogic Server Tools in Eclipse Juno

    668461
      Installing the WebLogic Server Tools in Eclipse (Juno) on Windows 7, 64 bit cannot be completed. Eclipse is up to date and several other plugins are installed.

      When installing the server tools, either via the Marketplace or the Server view -> New Server -> Download additional server adapters it fails because of incompatible dependencies. The error message is:

      -----
      Cannot complete the install because one or more required items could not be found.
      Software being installed: Oracle WebLogic Server Tools 2.2.0.201211211917 (oracle.eclipse.tools.juno.weblogic.feature.group 2.2.0.201211211917)
      Missing requirement: Oracle Eclipse Tools Environment Checker 5.2.0.201211211917 (oracle.eclipse.tools.envcheck 5.2.0.201211211917) requires 'bundle org.eclipse.ui [3.8.0,3.104.0)' but it could not be found
      Cannot satisfy dependency:
      From: Oracle Common Tools 2.2.0.201211211917 (oracle.eclipse.tools.juno.common.feature.group 2.2.0.201211211917)
      To: oracle.eclipse.tools.envcheck [5.2.0.201211211917]
      Cannot satisfy dependency:
      From: Oracle WebLogic Server Tools 2.2.0.201211211917 (oracle.eclipse.tools.juno.weblogic.feature.group 2.2.0.201211211917)
      To: oracle.eclipse.tools.juno.common.feature.group 0.0.0
      -----

      Does anyone know how to solve this and get the WebLogic Server Tools installed?

      rob schlüter

      Edited by: Rob Schlüter on Mar 11, 2013 3:12 AM