4 Replies Latest reply on Mar 14, 2013 12:14 PM by Michael Ferrante-Oracle

    error on webutil form in 11g froms


      i am facing an as frm-93652 the runtime process has terminated abnormally. Contact your System Administrator when i ran a form attached webutil.

      Please provide your solutions to help me out.

      Thanks in Advance,
        • 1. Re: error on webutil form in 11g froms
          Michael Ferrante-Oracle
          Please provide more details....
          <blockquote><li>Is this a new form you just created or one that previously worked?
          <li>Did you create a webutil.plx file?
          <li>When you generated your fmx, did you use the compile_all=yes option or do a Compile All PL/SQL from within the Builder?
          <li>Exactly which Forms version are you using?
          <li>Have you tried using the WebUtil Demo?
          • 2. Re: error on webutil form in 11g froms
            Hi Michael,

            I have created new form with attached webutil and used webutil demo form also, then getting same error.
            I done compile All in form builder.
            Form builder Version is 10g
            Server apps form version is 11g.

            • 3. Re: error on webutil form in 11g froms
              Alok Dubey
              If you are facing this issue with demo form, then u might have missed the configuration of webutil.
              • 4. Re: error on webutil form in 11g froms
                Michael Ferrante-Oracle
                Let me see if I understand... You are using a v10 Builder and running in v11. Well generally speaking this is fine although not at all recommended. There are a few potential problems with this in your case:

                1. The provided webutil.pll in v10 is not necessarily the same as the one in v11. So at design time you are using v10 and runtime v11. Again, this part is not the issue. The issue here is that if at runtime the app tries to access the old pll/plx (for example, maybe because the FORMS_PATH is incorrectly set) then a problem may arise. As mentioned, it is very important that the new webutil.pll be generated into a plx and be the only one that can be found in FORMS_PATH. Verify that no other webutil.plx files can be found.

                2. Are you creating the fmx in the v10 of v11 environment? A v10 fmx will not run in a v11 environment. You must use the v11 compiler to generate the modules (fmx, mmx, plx).

                3. You said, you did a compile_all pl/sql from within the Builder. Did you save before attempting to generate the fmx (and plx)?

                4. When you attempt to run the form, are you using a configuration (formsweb.cfg) that supports WebUtil?
                For example: http://server/forms/frmservlet?form=webutil_demo&config=webutil

                Exactly which Forms versions are you using? 10g and 11g are product names and not versions.