2 Replies Latest reply: Mar 13, 2013 12:51 PM by 848965 RSS

    Problem starting WebLogic domains on JRockit 27.6

      Hi All,

      Any ideas what could cause the following error when starting up WebLogic 10.3.0 on JRockit 27.6.0, 27.6.4, and 27.6.6 but not on 28.0.0?

      ####<Jun 24, 2010 4:04:25 PM CDT> <Critical> <WebLogicServer> <perf01> <aa01> <Main Thread> <<WLS Kernel>> <> <> <1277413465294> <BEA-000386> <Server subsystem failed. Reason: java.lang.Error: IP Helper Library GetAdaptersAddresses function failed
      java.lang.Error: IP Helper Library GetAdaptersAddresses function failed
           at java.net.NetworkInterface.getAll(Native Method)
           at java.net.NetworkInterface.getNetworkInterfaces(NetworkInterface.java:282)
           at weblogic.server.channels.AddressUtils$AddressMaker.getAllAddresses(AddressUtils.java:58)
           at weblogic.server.channels.AddressUtils$AddressMaker.<clinit>(AddressUtils.java:50)
           at weblogic.server.channels.AddressUtils.getIPAny(AddressUtils.java:105)
           at weblogic.protocol.configuration.ChannelHelper.checkConsistency(ChannelHelper.java:60)
           at weblogic.server.channels.ChannelService.start(ChannelService.java:197)
           at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
           at weblogic.work.ExecuteThread.execute(ExecuteThread.java:201)
           at weblogic.work.ExecuteThread.run(ExecuteThread.java:173)

      I'm installing new hardware (i.e. new to me, not new as in latest and greatest) and haven't come across this in the past. Thanks for any suggestions. This has had me baffled all day.