This discussion is archived
1 Reply Latest reply: Mar 14, 2013 1:22 AM by 996564 RSS

MIDlet not running. Failed to initialize connection with emulator 6.

967075 Newbie
Currently Being Moderated
I'm trying to run a simple midlet on Java ME SDK 3.0 integrated into Netbeans 7.1 on Windows 7 Ultimate (just a UI). It was running fine until yesterday but now its showing an error and i can't see the midlet in the emulator. I don't think its anything related to compatibility issues because the applications were running just fine the other day. Could someone help me rectify this glitch or whatever it is?


import java.io.IOException;
import javax.microedition.lcdui.*;
import javax.microedition.midlet.MIDlet;

public class Facebook extends MIDlet {

public void startApp() {
Form f = new Form("Facebook Login");
try {
Image g = Image.createImage("/Facebook 2.png");
ImageItem img = new ImageItem(null, g, Item.LAYOUT_CENTER, null, Item.PLAIN);
f.append(img);
} catch (IOException e) {
e.printStackTrace();
}
TextField tf = new TextField("Email or Phone", null, 300, TextField.ANY);
f.append(tf);
TextField tf1 = new TextField("Password", null, 300, TextField.ANY);
f.append(tf1);
ChoiceGroup cg = new ChoiceGroup(null, ChoiceGroup.MULTIPLE);
cg.append("Remember Me",null);
f.append(cg);
StringItem str = new StringItem(null, "Forgot Password?", StringItem.HYPERLINK);
f.append(str);
try {
Image g2 = Image.createImage("/Fb Login 2.png");
ImageItem img2 = new ImageItem(null, null, Item.LAYOUT_CENTER, null, Item.BUTTON);
f.append(img2);

} catch (IOException e2) {
e2.printStackTrace();
}
}

public void pauseApp() {
}

public void destroyApp(boolean unconditional) {
}
}


Message in output:


pre-init:
pre-load-properties:
exists.config.active:
exists.netbeans.user:
exists.user.properties.file:
load-properties:
exists.platform.active:
exists.platform.configuration:
exists.platform.profile:
basic-init:
cldc-pre-init:
cldc-init:
cdc-init:
semc-pre-init:
semc-init:
savaje-pre-init:
savaje-init:
sjmc-pre-init:
sjmc-init:
ojec-pre-init:
ojec-init:
cdc-hi-pre-init:
cdc-hi-init:
nokiaS80-pre-init:
nokiaS80-init:
post-init:
init:
conditional-clean-init:
conditional-clean:
deps-jar:
pre-preprocess:
do-preprocess:
Pre-processing 0 file(s) into F:\NetBeansProjects\MobileApplication2\build\preprocessed directory.
post-preprocess:
preprocess:
pre-compile:
extract-libs:
do-compile:
post-compile:
compile:
pre-obfuscate:
proguard-init:
skip-obfuscation:
proguard:
post-obfuscate:
obfuscate:
lwuit-build:
pre-preverify:
do-preverify:
post-preverify:
preverify:
pre-jar:
set-password-init:
set-keystore-password:
set-alias-password:
set-password:
create-jad:
add-configuration:
add-profile:
do-extra-libs:
nokiaS80-prepare-j9:
nokiaS80-prepare-manifest:
nokiaS80-prepare-manifest-no-icon:
nokiaS80-create-manifest:
jad-jsr211-properties.check:
jad-jsr211-properties:
semc-build-j9:
do-jar:
do-jar-no-manifest:
update-jad:
Updating application descriptor: F:\NetBeansProjects\MobileApplication2\dist\MobileApplication2.jad
Generated "F:\NetBeansProjects\MobileApplication2\dist\MobileApplication2.jar" is 998 bytes.
sign-jar:
savaje-prepare-icon:
savaje-build-jnlp:
post-jar:
jar:
pre-run:
netmon.check:
open-netmon:
cldc-run:
Copying 1 file to F:\NetBeansProjects\MobileApplication2\dist\nbrun7065826530940964495
Copying 1 file to F:\NetBeansProjects\MobileApplication2\dist\nbrun7065826530940964495
Jad URL for OTA execution: http://localhost:8082/servlet/org.netbeans.modules.mobility.project.jam.JAMServlet/F%3A/NetBeansProjects/MobileApplication2/dist//MobileApplication2.jad
Starting emulator in execution mode
*** Error ***
Failed to connect to device 6!
Reason:
Failed to initialize connection with emulator 6! (possible runtime incompatibility)
F:\NetBeansProjects\MobileApplication2\nbproject\build-impl.xml:782: Execution failed with error code 1.
BUILD FAILED (total time: 12 seconds)

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points