7 Replies Latest reply on Mar 15, 2013 5:15 PM by 997210


      I get this every time I start sqldeveloper. It operates normal when I click the OK button in the pop-up window but it is annoying would like for it to stop. Anyone have any suggestions?

           at oracle.jdevimpl.vcs.svn.SVNProfile.canActivate(SVNProfile.java:162)
           at oracle.jdevimpl.vcs.generic.GenericClient.fireCanActivate(GenericClient.java:1602)
           at oracle.jdevimpl.vcs.generic.GenericClient.canActivate(GenericClient.java:231)
           at oracle.jdevimpl.vcs.VCSManagerImpl$6.addinsLoaded(VCSManagerImpl.java:377)
           at oracle.ide.IdeCore.fireIdeEvent(IdeCore.java:872)
           at oracle.ide.IdeCore.access$100(IdeCore.java:137)
           at oracle.ide.IdeCore$3.run(IdeCore.java:844)
           at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
           at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
           at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
           at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
           at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
           at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
           at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
           at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
        • 1. Re: java.lang.NullPointerException
          That's the Subversion plugin - you can disable it in Preferences - Extensions - Versioning Support.

          Hope that helps,
          • 2. Re: java.lang.NullPointerException
            I have the same error, and after of disable the versioning extension everything works fine.

            • 3. Re: java.lang.NullPointerException
              Thanks guys, this annoying exeption doesn't disturb me anymore :-)
              • 4. Re: java.lang.NullPointerException
                I get this error as well. But I want to have Subversion working from within SQL Developer. Any ides appreciated?
                • 5. Re: java.lang.NullPointerException
                  I just went through the same thing...and I too needed to use subversion...

                  I downloaded the jdk from oracle and used the 'no-jdk' 3.1 version of sql developer ( i also had a 2.x version of sql developer that worked fine with subversion )...at first no joy

                  got the oracle.jdevimpl.vcs.svn.SVNProfile.canActivate(SVNProfile.java:162) error...every time

                  When I compared the preferences.xml file from

                  C:\Documents and Settings\<me>\Application Data\SQL Developer, I could see several directories reflecting the sql developer installations I had

                  In my 2.x installation ...

                  C:\Documents and Settings\<me>\Application Data\SQL Developer\system2.

                  I found the folder o.jdeveloper.subversion.

                  In there...I found preferences.xml...

                  In my
                  C:\Documents and Settings\<me>\Application Data\SQL Developer\system3.1.07.42 installation which at first did not work...

                  I found the
                  o.jdeveloper.subversion. folder...which also contained a preferences.xml file...however it was radically shorter and different than the 2.x version...

                  Copying the 2.x version to the 3.1 installation folder ( o.jdeveloper.subversion. )...and restarting sql developer did the trick...my subversion plug in now appears...

                  I have an SR opened with oracle to find out why the file got mangled in the first place...

                  • 6. Re: java.lang.NullPointerException
                    Same problem, slightly different solution:

                    I had an empty preferences.xml file in both the 2.0 and 3.1 sql developer, so I tried to simply delete the preferences.xml in the o.jdeveloper.subversion. directory and bingo - no error message any more.

                    Hope this helps someone
                    Best Regards
                    • 7. Re: java.lang.NullPointerException
                      thanks a lot