This discussion is archived
7 Replies Latest reply: Mar 15, 2013 3:26 PM by Msoares RSS

SMB Protocol Version on Zfs

Msoares Newbie
Currently Being Moderated
Hi,

It's seens that smb shares created with zfs share command are using smb 1.0; after some wireshark on Windows Machines, the protocol used is smb not smb2.

On previous versions, I could set this on /etc/samba/smb.conf (max protocol = SMB2). "- The Oracle Solaris 11 OS introduces a new method for sharing and managing SMB and NFS shares. The zfs command has been enhanced to manage shares and share properties on Solaris ZFS file systems. The zfs command now supports SMB and NFS sharing by means of the share, sharesmb, and sharenfs properties"

Is there a way to force zfs smb shares to exported on smb2?


Regards
M
  • 1. Re: SMB Protocol Version on Zfs
    bobthesungeek76036 Pro
    Currently Being Moderated
    Do a "man share_smb". These are the only options you may set.
  • 2. Re: SMB Protocol Version on Zfs
    Msoares Newbie
    Currently Being Moderated
    I've tried those before, no luck though. Nothing related to smb2.
  • 3. Re: SMB Protocol Version on Zfs
    cindys Pro
    Currently Being Moderated
    My very limited view is that if you create an SMB share of a Solaris ZFS file system, then the share should be available on Windows system running SMB or SM2. SMB and SM2 should interoperate, like different versions of NFS do. What is the actually problem?

    Thanks, Cindy
  • 4. Re: SMB Protocol Version on Zfs
    Msoares Newbie
    Currently Being Moderated
    cindys wrote:
    My very limited view is that if you create an SMB share of a Solaris ZFS file system, then the share should be available on Windows system running SMB or SM2. SMB and SM2 should interoperate, like different versions of NFS do. What is the actually problem?

    Thanks, Cindy
    Hi Cindy,

    I am able to connect to the shares.

    Windows Client can mount the share and after some time:

    Exception message: Failed to start monitoring changes to '\\sol11-zfs-01\mypool-fs0001\076\home' because the network BIOS command limit has been reached.

    I've created a linux box with smb2 and this error won't occour (samething happens on smb1-linux). I am not sure which feature exactly fixes this error.


    Using a cmdlet on win2012,

    PS C:\Windows\system32> Get-SmbConnection

    ServerName ShareName UserName Credential Dialect NumOpens
    ---------- --------- -------- ---------- ------- --------
    10.133.24.23 pool server\user server\uh-user 1.50 2


    Dialect is 1.5.
  • 5. Re: SMB Protocol Version on Zfs
    bobthesungeek76036 Pro
    Currently Being Moderated
    Probably won't be any help but this might explain why you are getting the error:

    http://support.microsoft.com/kb/810886/en-us

    If you have support you probably should open a case with the Big-O.
  • 6. Re: SMB Protocol Version on Zfs
    cindys Pro
    Currently Being Moderated
    Okay, good to know that the shares can be mounted but I'm not familiar with the Windows side at all.

    Maybe someone else can advise on this error.

    Exception message: Failed to start monitoring changes to '\\sol11-zfs-01\mypool-fs0001\076\home' because the network BIOS command limit has been reached.

    Thanks, Cindy
  • 7. Re: SMB Protocol Version on Zfs
    Msoares Newbie
    Currently Being Moderated
    The fix come from windows registry. There is a number of articles on this matter.

    Mainly: http://www.danieletosatto.com/2010/10/22/smb-tuning-for-xenapp-and-file-servers-on-windows-server-2008/

    Make sure the Zfs-Windows Clients increases the following Registry key:

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanworkstation\parameters]

    "MaxCmds"=dword:00000800

    When Zfs/Solaris ships full SMB2 and SMB3 this may to be required.

    Regards
    Marcus

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points