This discussion is archived
3 Replies Latest reply: Mar 18, 2013 5:17 AM by Ramprakash Arun RSS

Deployment of EAR file to Weblogic Server Failing

Shiva Shankar Explorer
Currently Being Moderated
Hi All,

I've an EAR file built from Jdev (11.1.1.5.1) deployed it to Weblogic 10.3.5.0 and it works fine, if I try to deploy it to another weblogic server(with Oracle Linux OS) with version 10.3.5.0 (via weblogic.deployer class ), I get the following error.

Task 7 initiated: [Deployer:149026]deploy application <application_name>[Version=V2.0] on DefaultServer.
Task 7 failed: [Deployer:149026]deploy application <application_name>[Version=V2.0] on DefaultServer.
Target state: deploy failed on Server DefaultServer
java.lang.ClassNotFoundException: oracle.apps.fnd.applcore.patterns.uaWebService.AtkHelpPortalService

The same set of Fusion Extension Bundles were used to configure both the integrated weblogic servers. Both the domains were created properly. Any specific thing I'm missing out on??

I had earlier posted it in adf forums, thought this was apt in here, so I've posted it here...

Thanks,
Shiva Shankar
  • 1. Re: Deployment of EAR file to Weblogic Server Failing
    Ramprakash Arun Newbie
    Currently Being Moderated
    Shiva,

    Is that you have built the EAR file in Jdev (11.1.1.5.1) deployed it to Weblogic 10.3.5.0 on Windows OS ?.

    Then You have tried same EAR with Weblogic server in Linux OS ? or Again you did built in Linux OS and deployed using weblogic.deployer option in cmd prompt !

    It seems pblm with installation and configuration of your App server.

    Try to create a new domain and deploy it.

    * Please Mark this if helpful for you *

    Regards,

    Ramprakash Arun.
  • 2. Re: Deployment of EAR file to Weblogic Server Failing
    Shiva Shankar Explorer
    Currently Being Moderated
    Hi Ram,

    Is the EAR file platform dependent?? Anyways I've tried to built the EAR from both the platforms. Re-creation of the domain also isn't helping (tried 3-4 times), each time it succeeds and doesnt give me any errors/warnings while creating the domain. Guess something else might be the issue. Do u think that there might be a problem with Fusion Extension Installers by any means??


    Thanks,
    Shiva Shankar
  • 3. Re: Deployment of EAR file to Weblogic Server Failing
    Ramprakash Arun Newbie
    Currently Being Moderated
    Fine shiva,

    So we need to narrow down the issue with other directions,

    1. Domain - checked as you verified with creating new domain
    2. Ear package - checked as you did new build with Linux machine.

    Now we will focus on the command side,

    Check the setWLSEnv.sh file having all required details ( class-path ) to execute weblogic.Deployer command.

    And like try this

    java weblogic.Deployer -adminurl t3://adminserver:7001
    -username myuser -password welcome1 -name HRServices
    -source /usr/HRServices.ear -targets serverA -deploy

    And reply with the all logs if issue persist.

    If this kind of workouts are not helping to fix then we will go with directory structure verification for your EAR, Fusion Extension Installers, etc ..,

    * Please Mark this if helpful for you *

    Regards,

    Ramprakash Arun.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points