4 Replies Latest reply: Mar 18, 2013 2:28 AM by 925715 RSS

    Getting error while deploying EAR file???

    925715
      Hi Everyone,

      My Jdev version is 11.1.2.3.0.
      I have developed one ADF application and successfully deployed into stand alone web logic server from Jdeveloper itself(By creating application server in Jdeveloper and deployed directly from Jdeveloper).
      But when i undeployed the application from server and tried to deploy from server itself from the same EAR file its showing below error after clicking on Activate changes:
      "
      Message icon - Error An error occurred during activation of changes, please see the log for details.
      Message icon - Error weblogic.application.ModuleException:
      Message icon - Error java.security.PrivilegedActionException: weblogic.common.ResourceException: java.security.PrivilegedActionException: weblogic.common.ResourceException: No credential mapper entry found for password indirection user=ABC for data source XYZ"

      Any suggestions will be really useful.

      Thanks.
        • 1. Re: Getting error while deploying EAR file???
          Timo Hahn
          Looks like you are not using jdbc datasource but jdbc url. You should use jdbc data source as the connection type. right click on your application module and select 'Configurations...' then edit the configurations and select 'jdbc datasource' from the list box.
          Then you should edit the applications deployment descriptor (you find this in the application properties) and remove the check mark from the 'Auto generate and synchronize ...'. This means that you have to define the data source on the stand alone server as jdev now does not do this your you (with the wrong credentials). This is the way to go when you deploy to a stand alone server as you can't guarantee that the connection information is allways the same for all servers you deploy to (e.g. production uses a different DB).

          Timo
          • 2. Re: Getting error while deploying EAR file???
            Frank Nimphius-Oracle
            Hi,

            Go to your Application Properties (JDeveloper --> Application menu) and the Deployment section therein. Uncheck the option "Auto Generate and Synchronize weblogic-jdbc.xml Descriptors During Deployment" and deploy the application again. If you don't do this then JDeveloper creates data source entries for all your configured database connections in JDeveloper but without the password. Instead it expects an indirection setting to point to the password on teh server side, which doesn't exist in your case. If you uncheck the option I mention above, all you need to make sure is that the Java EE data source used in the application s available on the target server.

            Frank
            • 3. Re: Getting error while deploying EAR file???
              925715
              Hi Timo,

              Thanks for ur quick response.
              Already i have selected jdbc data source as the connection type and also removed the check mark from the 'Auto generate and synchronize'.
              FYI, i am running application from Jdeveloper through data source only.

              What can be the issue?
              Please give any suggestions.

              Thanks.
              • 4. Re: Getting error while deploying EAR file???
                925715
                Hi Timo and Frank,

                Thanks for ur responses.
                I got the solution the problem was with my Data Source password in the server.


                Thanks.