This discussion is archived
3 Replies Latest reply: Mar 19, 2013 8:34 AM by Dude! RSS

OEL 5.5 - Unable to configure xserver

user743048 Newbie
Currently Being Moderated
Hi

I have installed OEL 5.5 on a brand new laptop. Not on the VM. I formatted the HD and have done a complete OEL 5.5 install.

This is a HP Pavilion dm4 system

i 'm trying to configure and start xserver .. but getting the following error ..

Error
--------
Synaptics unable to query/initialize Synaptics hardware
Preinit failed for input device "Synaptics"

Fatal server error
failed to initialize core devices
X10: fatal IO error 104 (Connection reset by peer) on X server

--------------------------------------------------------------------------------------

After using google i think it may be due to the driver missing for the mouse.

I tried to download xf86-input-synaptics-1.6.2.tar.gz from
http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/snapshot/xf86-input-synaptics-1.6.2.tar.gz

I unzipped this But was unable to install this. since the readme does not provide how to use this file.

Any document or pointers that would help me ..would be greatly appreciated.

Thanks

P.S. I also tried other methods but it requires additional packages or tools or versions like Slackware.. not sure the dependencies and compatibility with OEL 5.5
  • 1. Re: OEL 5.5 - Unable to configure xserver
    Dude! Guru
    Currently Being Moderated
    Your mileage to install any OS on unsupported hardware will vary, in particular when trying to install an old and obsolete version. You may have more luck choosing a desktop Linux distribution such as Fedora or Ubuntu or use Windows and install Oracle Linux under a virtualization product like free Oracle VirtualBox.

    Your very last resort if you insist to install Enterprise Linux on your computer might be to compile the driver from source code and install the necessary kernel support yourself or check http://elrepo.org/tiki/tiki-index.php and use Oracle Linux with the original RHEL kernel.
  • 2. Re: OEL 5.5 - Unable to configure xserver
    user743048 Newbie
    Currently Being Moderated
    Thanks Dude. Even i 'm leaning towards using Oracle VM. When i have time i will try both and will update this thread of the findings.
  • 3. Re: OEL 5.5 - Unable to configure xserver
    Dude! Guru
    Currently Being Moderated
    Oracle VM Server will not help you. Oracle VM server is a type 1 hypervisor which installs it's own system software, repalcing any existing OS. You will run into the same trouble. What you need is a type 2 virtualization, such as Oracle VM VirtualBox.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points