This discussion is archived
6 Replies Latest reply: Apr 16, 2013 10:55 AM by PetervanNesatTheFutureGroup RSS

No application stripe in EM application roles

PetervanNesatTheFutureGroup Newbie
Currently Being Moderated
Hi,

I am working on an automated install of a Weblogic 10.3.6 domain with Oracle BI Publisher 11.1.1.6.8.
The installation completes successfully, but when opening the Application Roles in EM for the created domain, there are no Applications Stripes selectable (empty list).
In short the installation process does;

* Install jrockit, wls 10.3.6, install obi 11.1.1.6 and BP8 in the MW_HOME
* Create repository
* Create a domain
* Create an AdminServer
* Create a Machine
* Create a BIP_Cluster
* Create a Managed Server and assign it to the BIP_Cluster
* Retarget applications and libraries created by template oracle.bipublisher_template_11.1.1.jar from AdminServer to BIP_Cluster

Nothing fancy, but in the end the application roles for BI are not showing up in EM. I have tried the same installation with WLS 10.3.5, obi 11.1.1.6. without BP8 but no luck till now.
Anyone with any hints why the roles do not show up in EM.
  • 1. Re: No application stripe in EM application roles
    Nilum Explorer
    Currently Being Moderated
    Hi,

    What is the application you installed(ADF,etc)?
    Is this application contains security roles in file(Jazn-data.xml)?.

    Nilum.

    Edited by: Nilum on Mar 18, 2013 10:55 PM
  • 2. Re: No application stripe in EM application roles
    PetervanNesatTheFutureGroup Newbie
    Currently Being Moderated
    I am installing Oracle BI Publisher 11.1.1.6.8.
    There should be security roles in the jazn-data file but are not there after installation.
  • 3. Re: No application stripe in EM application roles
    Nilum Explorer
    Currently Being Moderated
    Hi,

    Check your application name/application stripe in the $domain/config/fmwconfig --> system-jazn-data.xml.
    This is the file that application stripe store. Under this application stripe your application roles should map.

    Your jazn-data file polices migrate to system-jazn-data file when application installation.
    Check the file size of original(before app install) system-jazn-data and after install the app.

    Nilum.
  • 4. Re: No application stripe in EM application roles
    PetervanNesatTheFutureGroup Newbie
    Currently Being Moderated
    Hi Nilum,

    The roles do not appear in the system-jazn-data.xml after the installation of OBI.
    Although i found the MW_HOME/bifoundation/provision a policystore-template.xml containing the roles i am not able to find out how to apply this template.
    When installing the product using the wizards (manually) the roles do appear, so probably i am missing something when installing it using a wlst script (using the standard templates).
    <?xml version="1.0" encoding="UTF-8"?>
    <jazn-data>
        <policy-store>
            <applications>
                <application>
                    <name>obi</name>
                    <app-roles>
                        <app-role>
                            <name>BISystem</name>
                            <display-name>BI System Role</display-name>
                            <class>oracle.security.jps.service.policystore.ApplicationRole</class>
                            <members>
                                <member>
                                    <class>weblogic.security.principal.WLSUserImpl</class>
                                    <name>BISystemUser</name>
                                </member>
                            </members>
                        </app-role>
                        <app-role>
                            <name>BIAdministrator</name>
                            <display-name>BI Administrator Role</display-name>
                            <class>oracle.security.jps.service.policystore.ApplicationRole</class>
                            <members>
                                <member>
                                    <class>weblogic.security.principal.WLSGroupImpl</class>
                                    <name>BIAdministrators</name>
                                </member>
    <!-- external-biadministrator-members -->
                            </members>
                        </app-role>
                        <app-role>
                            <name>BIAuthor</name>
                            <display-name>BI Author Role</display-name>
                            <class>oracle.security.jps.service.policystore.ApplicationRole</class>
                            <members>
                                <member>
                                    <class>weblogic.security.principal.WLSGroupImpl</class>
                                    <name>BIAuthors</name>
                                </member>
                                <member>
                                    <class>oracle.security.jps.service.policystore.ApplicationRole</class>
                                    <name>BIAdministrator</name>
                                </member>
    <!-- external-biauthor-members -->
                            </members>
                        </app-role>
    ...
  • 5. Re: No application stripe in EM application roles
    855667 Newbie
    Currently Being Moderated
    This blog post may help. http://www.rittmanmead.com/2009/10/installing-bi-publisher-into-weblogic-servier-11g/

    Thanks,
    Jonathan Johnson
  • 6. Re: No application stripe in EM application roles
    PetervanNesatTheFutureGroup Newbie
    Currently Being Moderated
    Thanks,

    But this article is from 2009 and about installing BI Publisher 10g on weblogic 11g.
    We will probably the first one installing OBIEE using wlst and wl templates.
    Getting there step-by-step.

    Cheers
    Peter

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points