4 Replies Latest reply: Mar 21, 2013 9:16 AM by KarstenH-dk RSS

    profiler

    KarstenH-dk
      When using profiler i SQL-developer 3.2 (Hierachical profiler)
      SQL-developer insists on creating a directory called PLSHPROF_DIR.

      (Later in the creation of a profile, you are supposed (as sys) to create a
      DIRECTORY_PATH to the file-system for this (PLSHPROF_DIR) and besides
      grant read and write permission to this directory).

      This seems to be a bit complicated in my case, because I already have a lot of
      usable directories equipped with the sufficient permissions;
      but it is not possible to use these Directories from SQL-developer.

      Now I have to wait for my dba to permit me using PLSHPROF_DIR and the worst thing is
      I have to run through this (create/grant PLSHPROF_DIR) procedure for every user on my
      databases which is a bit tedious, as I already have usable directories.

      regards Karsten
        • 1. Re: profiler
          Gary Graham-Oracle
          Hi Karsten,

          I don't believe there has been any enhancement request logged for this yet -- you might want to try doing that officially (through Oracle Support) or unofficially (SQL Developer exchange http://sqldeveloper.oracle.com/).

          In fact, there seems to have been an effort to provide a preference setting for this in
          Tools -> Preferences -> Database -> PL/SQL Compiler
          but the developer encountered some problem and disabled the code. If you wish to experiment, there may be a possibility of overriding the default of PLSHPROF_DIR in your user settings product-preferences.xml file. Look for:
          <value n="PLSQLPROFILERDIR" v=""/>
          If it does not work, I recommend getting some sort of enhancement request logged.

          Regards,
          Gary
          SQL Developer Team
          • 2. Re: profiler
            KarstenH-dk
            Hi
            Thank you for answering, but
            The value PLSQLPROFILERDIR does not exists in my product-preferences.xml
            Is it possible to add it ?

            regards Karsten
            • 3. Re: profiler
              Gary Graham-Oracle
              If it is not already in product-preferences.xml, just open
              Tools -> Preferences -> Database -> PL/SQL Compiler
              click OK without changing anything, exit SQL Developer, then edit product-preferences.xml as desired.

              Hope this works for you,
              Gary
              • 4. Re: profiler
                KarstenH-dk
                Tried overriding the default of PLSHPROF_DIR in my user settings product-preferences.xml file, but unfortunately SQLdeveloper ignores it.
                I therefore logged an enhancement request.

                thank you, regards Karsten